summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
commit8973f70e9a2ae4ea8a324e607ea1e8b96c7ff384 (patch)
treebbe587aee6b255e6cc44d4fd753d1cb9dbd1cfce /app-editors
parentf29a41111b3a606f5d95049b1ba92daabbc68cc0 (diff)
gentoo auto-resync : 05:01:2023 - 18:09:32
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin14251 -> 14253 bytes
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-44.0.ebuild105
-rw-r--r--app-editors/gedit/Manifest2
-rw-r--r--app-editors/gedit/gedit-44.1.ebuild89
-rw-r--r--app-editors/gnome-latex/Manifest2
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.44.0.ebuild50
7 files changed, 250 insertions, 0 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index 7e72364d02e7..f63acfd1aeb5 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index df722a22db9f..1dd92c51e992 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-43.1.tar.xz 913072 BLAKE2B ebfaa6311aac490c75339cf506a58ce60864925ebee8284d72cc4b42634696511d7060eca1b8988d574e1b17dc0e0d32cc934da3c29421339044a220ea5e854e SHA512 2aad05ce15e148121b8e0dcf59546061e448aac09f42c28cee7dfc0b3c16965716059cf147c6391f1c439ac04241e94384bf6ff8dfaa40303dfe80d8de1e2fbc
+DIST gedit-plugins-44.0.tar.xz 913176 BLAKE2B 325b70566ba32d6f10edf1681df6d31bf10329389331c9ef4a89671da1b538ff4faebd07c224d5309a113fbb28d40b777fc34c27b8ab1c894abdfeeb2d3683b6 SHA512 878fb3df8ab4e9a338b25da7a8c89c8d8c2dadb78095d2c620448423a2c506e7ab4ac27e823452f0c624ecab97766cc35385271d5889f58a5963b0e343bd63ae
EBUILD gedit-plugins-43.1.ebuild 2587 BLAKE2B b11a55b0bdc122ad21906a09e8e0e45424a6767eeef6fd7ba52e34703968a21a1a583178d7b0419f79e066f4ee944b4820fe57b2ed64bcf58d7a28e50ce92c31 SHA512 a278ef3a963bfd7d2a3b040e8bab110e97a42c909193b99429daa62685e0060a8f6a2b905914ca821a677aa01ccdc191528dba72e2e2aab2a8be0dedba57263e
+EBUILD gedit-plugins-44.0.ebuild 2589 BLAKE2B 09230b7815f03b507a433391077a52c4090d5d90ac2ba3624844790a5ad0c3e0a41dcd91df799a8d765c2f0c18d621fe69bfab0e3c9a27ee27a4f824fcb3c42e SHA512 8b9212844b03c1a585dfe0d4a8a6e2a4c1a34b8ec79c576595213c856fd5acd7a031272b42b6d0065670b7ceee0dea7d6cab38f730f4eb328aef0ebedbacdc74
MISC metadata.xml 596 BLAKE2B cf545e591c160fc584c5c2b1e3f5fa6a47922a958f981daa5c85f3f6c8f7eaed2a520d6265241998dfe211098f70c75a0fdfff033e55e892e5775b678ea9ef5b SHA512 0a3b9e748bc2d22ea16a694f8ebd6196d05e6652f552523bfe6fa60f1c69ab50110692cda7a59239c8f6946c06d3139a4225f1744e0dd40ccbdef3e8b396f692
diff --git a/app-editors/gedit-plugins/gedit-plugins-44.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-44.0.ebuild
new file mode 100644
index 000000000000..167eb07b5d61
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-44.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ThirdPartyPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-44.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ -Dplugin_drawspaces=true
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index d4d6b442b1d1..47e9dc406d28 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,3 +1,5 @@
DIST gedit-43.2.tar.xz 2724036 BLAKE2B 64039018c604874945cc6835bba14d80f969b0a860c0384d969af7fc81cdc4ade568539a80571440af605f14eaf33730140a48b48b92d1bdb652199770ca3411 SHA512 447f0da946ff7474637bb6b88f41eb53e5ba886c66e8b9f8c17e67d2f52e3eb115d905a850300f70488cfebcd6654a14ce8c57044760f4fdb3394cedf4e91f23
+DIST gedit-44.1.tar.xz 2735700 BLAKE2B 275a614993c4a38d52455eb22c435697a452069f62b4332b4df8b1b83daa18192fa2159162387996122144645069500d3d48826d05a4b4133df285af387a8f52 SHA512 7eb48c8020726e0648565abff6aca32ddf464bc651c2e2298402b9ee3ff8c6ba64d4becc6da3290ac8a4b58705a5f3e09b7958a6cebe357d701708c525d6e3df
EBUILD gedit-43.2.ebuild 1770 BLAKE2B c48e25944efb1d716db31d8b7340a08c1ba5ebb89aac5bfe458478f2114db5d11ef28262a3e899cb09a52342d9bd4c773988a1a0b560dbd275b2c5d3bcb013f5 SHA512 3473bf78bc6f154279893813448a185fa0646be36092642e09ff767be2792cb6a999e886c5751e776ccd82089d4e652a4c280d7609e3647e46f33787589762b5
+EBUILD gedit-44.1.ebuild 1773 BLAKE2B c65f8b0645b54501570dfe30818397eeeb2b7f595269ce186feec4e83dea647212d0ef0c09d4827f27e4c929eb5971456df15c97d0171436133af988ae626c00 SHA512 e723c24fd9a84a69a1848d01896fd86edc05189a0224f42aa74080787ddc6e7274925d09cdea8d2bcfacc409d990837597142141059d2dc1f380b67905d3ec69
MISC metadata.xml 346 BLAKE2B 59226b3220bd9b1770fad0f5acf3b1888a57a3496f9e0a6eb0eb09c12b7a5aa461961753dd8a5a6f01db1cdb97af5b28d6a8d1d632b60f499f86e0864e29264f SHA512 3e1d83ad67b85a681b85f8fece9d6c2c3eab2f2f726447230dc1f2399a21cba211d97e11d8c06d0d1b1803fafe67be4b32c04b39c5f8586a421c525624f6697d
diff --git a/app-editors/gedit/gedit-44.1.ebuild b/app-editors/gedit/gedit-44.1.ebuild
new file mode 100644
index 000000000000..a0ccacb2d2c6
--- /dev/null
+++ b/app-editors/gedit/gedit-44.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+python gtk-doc"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/amtk-5.6:=
+ >=gui-libs/tepl-6.4:=
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=app-text/gspell-0.2.5:0=
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+
+ >=x11-libs/gtksourceview-4.0.2:4[introspection,vala]
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_documentation=true
+
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/gnome-latex/Manifest b/app-editors/gnome-latex/Manifest
index 7aef5175c58d..07d57d5dcd56 100644
--- a/app-editors/gnome-latex/Manifest
+++ b/app-editors/gnome-latex/Manifest
@@ -1,3 +1,5 @@
DIST gnome-latex-3.42.0.tar.xz 1170904 BLAKE2B 0bd1b3c50910f70d5ef690bbc9d755a61f6e076c4a491662be77ffeb5985d50c664323c7e743d108bc65fd2c826ee12cf28076a0bfb1111cc2a922381b02034c SHA512 b36300226344eced21a694ecfa6aaef0b1e788ebbc461e0ae57adab30361bc6765c6b0136213ecf19e5b61ddbb35ac5c832fb21b6f1e7f555564bb372d5f2c7b
+DIST gnome-latex-3.44.0.tar.xz 1168840 BLAKE2B 7eb34502a9bcdcbb5c8e2d8336a3029fad1cdd1da0cbd704fae4de44a3aab913ed43228172dfe7798c7a513a61664fd8af97df0aff66d62f8502edbe845ac12f SHA512 d1dc7b2321438ebed7a209c7c750123a0dcf8ebcf92f73fd7eb4c79282f51d6b6a8328ee8759326f43e53dbd2ba9d1fadc056c2fcea11e7785e7c27574707e95
EBUILD gnome-latex-3.42.0.ebuild 1088 BLAKE2B 6cea8625ad96095f5b6679daeb3833820482f56fc8aaaa545e853db2c6f2ce3f2cd533110c9b8d32dd9a04d316676df04c9a0ef0f02d2e8c11590411e484f0d3 SHA512 5c04602c15b652cf7d83f34805c9e0abaacb8183c7fa7e2d1179dd65bd1c93a133982efe0a14427f6e7f330069390a48df9964ba0516de5bf7b982ba4ee225ab
+EBUILD gnome-latex-3.44.0.ebuild 1090 BLAKE2B 8eb1456dc77bd47f1c39baa6603166a495b89133e079594efdfd4ff5db03fb74b9a4318528e74079367517d5cba5a5d5bc9efcaba51f6af3c1108e8efbf3909d SHA512 1c0edd205f6851d573c400d8800cbd982717a1eb3b41445cbc93140eaedcff98fdc09c8d3d7a57b03dac44736cf8ad87674d327ff0cb303799df1aaa10c14bf6
MISC metadata.xml 575 BLAKE2B 73604444b6c40826ddad63c484b35ed2bb7c3edf6ab59e40994881769051c96b2ebb211d47d2f67b562c48e15ca589863f6cad9984accaf40567bc8f697b15e6 SHA512 6a6bbbcd0f1e3119f624828a3f008d12377c835f4235fe6fe232f326dc8d3bcc960406d1c33ababd00b0a941f9c7160c3f6a7b106a9f70ccb505b0eb0349e5b6
diff --git a/app-editors/gnome-latex/gnome-latex-3.44.0.ebuild b/app-editors/gnome-latex/gnome-latex-3.44.0.ebuild
new file mode 100644
index 000000000000..ee592d7e3c1a
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.44.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/swilmet/gnome-latex"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+introspection +latexmk rubber"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22:3
+ >=app-text/gspell-1.8:0=
+ >=gui-libs/amtk-5.6:=
+ >=x11-libs/gtksourceview-4.0:4
+ >=gui-libs/tepl-6.4:=
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.6:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration \
+ --enable-vala=no
+}