summaryrefslogtreecommitdiff
path: root/app-editors/xemacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
commitec9f79e1d3358df31a704f16a76a269ccceae2b2 (patch)
tree5982c029d09bc9e396ad5ead3d99c99ed6a58322 /app-editors/xemacs
parent9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (diff)
gentoo auto-resync : 24:12:2022 - 20:03:07
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/Manifest1
-rw-r--r--app-editors/xemacs/xemacs-21.5.34-r13.ebuild259
2 files changed, 260 insertions, 0 deletions
diff --git a/app-editors/xemacs/Manifest b/app-editors/xemacs/Manifest
index 34168ace8e4e..b916a5a2427f 100644
--- a/app-editors/xemacs/Manifest
+++ b/app-editors/xemacs/Manifest
@@ -22,5 +22,6 @@ DIST xemacs-21.5.34.tar.gz 15816932 BLAKE2B e3be282717b91308c94d3d4bee74527d0b31
EBUILD xemacs-21.4.24-r10.ebuild 7141 BLAKE2B 3a5bb7ce551de9c132fe8549d3337421f01b01325df647c98719a45a97ad68208be784fde9bd5b2dd856543d8899db3aaf08c072613e57e26ec5348dd0a714f3 SHA512 9e0d6bb0afca815a6ea0f007e857c7ed3ba05b3e4f10ad5bd2bb14bf4087fcd5371176e244f0fd93d9ac86a4e60a3f4dc4930e49acf5082d20b65eb537fe1dac
EBUILD xemacs-21.4.24-r9.ebuild 7113 BLAKE2B b0cff6b002ee49f80b289e810c7f46c6864ccc60e7064a27857df148246999cb7c892a04bbf7e4d3cc37d55e49eb44bbf5a79fdb3d16983bbb3c5f4a01418e72 SHA512 1bf2721acc322fd1db5291ba54e43d0892ac5a925e88d7a69cc055cb7819d3ce341aef9e0a722ce329bcbb18f7cbc4380731a52c016b691f8382e33d21b0659d
EBUILD xemacs-21.5.34-r12.ebuild 7398 BLAKE2B 164e4216ee89823cceaa87e264b44d195704e43d121364d4fee887ab16dceb7fc591dbeafd0ec4a748381ea870847c6bc197d6584656d5fb5b637ddf967fd5ea SHA512 74474d406b3b6ac27f52f57abe4b5a77e447a90630780d217efd872998d7a3ec8ac276ca2a6e6a56be89167bd4f8d7d6751ce4bb09d928034fbe3c6788d8fc4d
+EBUILD xemacs-21.5.34-r13.ebuild 7433 BLAKE2B 51aae54f90e68f6cee6671432443e9dd68a2ecb1eb494d8e31e7ecfa768fe263788c6da06145ea5c6713db63059cfd9eb9a8b17a1fc50115bd1c968e2b8b8cea SHA512 a92653bef140fb120f005d3cc8ab1b098aa79a9c9d989a0aa5bf3821f33a9ce7fb2d3801765fffdb3bab3ca8de86ea213712009110e77789d63355833c4892f0
EBUILD xemacs-21.5.9999.ebuild 7226 BLAKE2B d0d5335ff61e34d024f2675f5a8cb1b20ad605cfe1cdd89d684b4c37b8480fbea4eed7135e5348a8af114a072032dd01c428c9ded66e9ea752306e4e45e6f816 SHA512 4acd7d2096d23319709a97f7f6f75ddf4d9819751e855df171c0141980a3c9d18848d46cdaee2c93b4ae2a19aaf55519a81273be4ea6baed400747a0d3dba3fc
MISC metadata.xml 683 BLAKE2B 060e4f7830a96404813a550debecf83c2de3993183d41638362ed01a3a6240bdd33a83c0db5e31a2f2e821046fb1c15199688271c27611689aac1bdf02bcde14 SHA512 176625d3c972766aaecd10125e69b4cdcbedff958b842b2ac2b6a39d728ec868b3311ef13f6854122063810c5125f48d73cd1e68083de5ddf3ef85f7f2b09cdc
diff --git a/app-editors/xemacs/xemacs-21.5.34-r13.ebuild b/app-editors/xemacs/xemacs-21.5.34-r13.ebuild
new file mode 100644
index 000000000000..d257f4c26662
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.5.34-r13.ebuild
@@ -0,0 +1,259 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: xemacs currently does not work with position independent code
+# so the build forces the use of the -no-pie option
+
+EAPI=8
+
+inherit flag-o-matic xdg-utils desktop
+
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="https://www.xemacs.org/"
+SRC_URI="http://ftp.xemacs.org/xemacs-$(ver_cut 1-2)/${P}.tar.gz
+ neXt? ( http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa debug gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn xft xim athena neXt Xaw3d gdbm berkdb"
+
+X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
+
+RDEPEND="
+ berkdb? ( >=sys-libs/db-4:= !!<sys-libs/db-4 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3:=[berkdb(+)] )
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.6:0=
+ >=media-libs/audiofile-0.2.3
+ gpm? ( >=sys-libs/gpm-1.19.6 )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( net-nds/openldap:= )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ X? ( $X_DEPEND !Xaw3d? ( !neXt? ( x11-libs/libXaw ) ) )
+ dnd? ( x11-libs/dnd )
+ motif? ( >=x11-libs/motif-2.3:0[xft=] )
+ athena? ( x11-libs/libXaw )
+ Xaw3d? ( x11-libs/libXaw3d[unicode(+)] )
+ xft? ( media-libs/freetype:2 x11-libs/libXft x11-libs/libXrender >=media-libs/fontconfig-2.5.0 )
+ neXt? ( x11-libs/neXtaw )
+ xface? ( media-libs/compface )
+ tiff? ( media-libs/tiff:= )
+ png? ( >=media-libs/libpng-1.2:0 )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ freewnn? ( app-i18n/freewnn )
+ >=sys-libs/ncurses-5.2:=
+ >=app-eselect/eselect-emacs-1.15"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PDEPEND="app-xemacs/xemacs-base
+ mule? ( app-xemacs/mule-base )"
+
+src_unpack() {
+ default_src_unpack
+}
+
+src_prepare() {
+ use neXt && cp "${WORKDIR}"/NeXT.XEmacs/xemacs-icons/* "${S}"/etc/toolbar/
+ find "${S}"/lisp -name '*.elc' -exec rm {} \; || die
+ eapply "${FILESDIR}/${P}-ncurses-tinfo.patch"
+ eapply "${FILESDIR}/${P}-gcc5.patch"
+ eapply "${FILESDIR}/${P}-glibc-macro.patch"
+ eapply "${FILESDIR}/${P}-as-needed.patch"
+ eapply "${FILESDIR}/${P}-configure-libc-version.patch"
+ eapply "${FILESDIR}/${P}-ar.patch"
+ eapply "${FILESDIR}/${P}-strsignal.patch"
+ eapply "${FILESDIR}/${P}-process-test-qa.patch"
+ eapply "${FILESDIR}/${P}-autoloads-parallell-make.patch"
+ eapply "${FILESDIR}/${P}-no-lock-on-finder-inf.patch"
+ eapply "${FILESDIR}/${P}-module-autoloads.patch"
+
+ eapply_user
+
+ # Some binaries and man pages are installed under suffixed names
+ # to avoid collions with their GNU Emacs counterparts (see below).
+ # Fix internal filename references.
+ sed -i -e 's/exec gnuclient/&-xemacs/' lib-src/gnudoit || die
+ sed -i -e '/^\.so/s/etags/&-xemacs/' etc/ctags.1 || die
+ sed -i -e '/^\.so/s/gnuserv/&-xemacs/' etc/gnu{client,doit,attach}.1 || die
+}
+
+src_configure() {
+ local myconf=""
+
+ # bug #639642
+ test-flags -no-pie >/dev/null && append-flags -no-pie
+ filter-flags -pie
+
+ if use X; then
+
+ myconf="${myconf} --with-widgets=athena"
+ myconf="${myconf} --with-dialogs=athena"
+ myconf="${myconf} --with-menubars=lucid"
+ myconf="${myconf} --with-scrollbars=lucid"
+ if use motif ; then
+ myconf="--with-widgets=motif"
+ myconf="${myconf} --with-dialogs=motif"
+ myconf="${myconf} --with-scrollbars=motif"
+ myconf="${myconf} --with-menubars=lucid"
+ fi
+ if use athena or use Xaw3d ; then
+ myconf="--with-scrollbars=athena"
+ fi
+
+ if use Xaw3d; then
+ myconf="${myconf} --with-athena=3d"
+ elif use neXt; then
+ myconf="${myconf} --with-athena=next"
+ else
+ myconf="${myconf} --with-athena=xaw"
+ fi
+
+ use dnd && myconf="${myconf} --with-dragndrop"
+
+ myconf="${myconf} $(use_with tiff )"
+ myconf="${myconf} $(use_with png )"
+ myconf="${myconf} $(use_with jpeg )"
+ myconf="${myconf} $(use_with xface )"
+
+ use xft && myconf="${myconf} --with-xft=emacs,tabs,menubars,gauges" ||
+ myconf="${myconf} --with-xft=no"
+
+ else
+ myconf="${myconf}
+ --without-x
+ --without-xpm
+ --without-dragndrop
+ --with-xft=no
+ --with-gif=no"
+ fi
+
+ if use mule ; then
+ myconf="${myconf} --with-mule"
+
+ if use xim ; then
+ if use motif ; then
+ myconf="${myconf} --with-xim=motif"
+ else
+ myconf="${myconf} --with-xim=xlib"
+ fi
+ else
+ myconf="${myconf} --with-xim=no"
+ fi
+
+ myconf="${myconf} $(use_with freewnn wnn )"
+ fi
+
+ # This determines the type of sounds we are playing
+ local soundconf="native"
+
+ # This determines how these sounds should be played
+ use nas && soundconf="${soundconf},nas"
+ use alsa && soundconf="${soundconf},alsa"
+
+ myconf="${myconf} --with-sound=${soundconf}"
+
+ if use gdbm || use berkdb ; then
+ use gdbm && mydb="gdbm"
+ use berkdb && mydb="${mydb},berkdb"
+
+ myconf="${myconf} --with-database=${mydb}"
+ else
+ myconf="${myconf} --without-database"
+ fi
+
+ use debug && myconf="${myconf} --with-debug" ||
+ myconf="${myconf} --with-optimization --with-cflags-debugging="
+
+ econf ${myconf} \
+ $(use_with gif ) \
+ $(use_with gpm ) \
+ $(use_with postgres postgresql ) \
+ $(use_with ldap ) \
+ $(use_with pop ) \
+ --prefix=/usr \
+ --without-canna \
+ --with-ncurses \
+ --with-msw=no \
+ --with-mail-locking=flock \
+ --with-site-lisp=yes \
+ --with-site-modules=yes \
+ --with-system-malloc \
+ --enable-option-checking=no \
+ --with-last-packages=/usr/lib/xemacs
+}
+
+src_compile() {
+ emake EMACSLOADPATH="${S}"/lisp
+}
+
+src_install() {
+ emake prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man/man1 \
+ infodir="${ED}"/usr/share/info \
+ libdir="${ED}"/usr/$(get_libdir) \
+ datadir="${ED}"/usr/share \
+ install
+
+ # Rename some applications installed in bin so that it is clear
+ # which application installed them and so that conflicting
+ # packages (emacs) can't clobber the actual applications.
+ # Addresses bug #62991.
+ for i in b2m ctags etags gnuclient gnudoit gnuattach; do
+ mv "${ED}"/usr/bin/${i} "${ED}"/usr/bin/${i}-xemacs || die "mv ${i} failed"
+ done
+
+ # rename man pages
+ for i in ctags etags gnuserv gnuclient gnudoit gnuattach; do
+ mv "${ED}"/usr/share/man/man1/${i}{,-xemacs}.1 || die "mv ${i}.1 failed"
+ done
+
+ # install base packages directories
+ dodir /usr/lib/xemacs/xemacs-packages/
+ dodir /usr/lib/xemacs/site-packages/
+ dodir /usr/lib/xemacs/site-modules/
+ dodir /usr/lib/xemacs/site-lisp/
+
+ if use mule;
+ then
+ dodir /usr/lib/xemacs/mule-packages
+ fi
+
+ # remove extraneous info files
+ cd "${ED}"/usr/share/info
+ rm -f dir info.info texinfo* termcap* standards*
+
+ cd "${S}"
+ dodoc CHANGES-* ChangeLog INSTALL Installation PROBLEMS README*
+
+ newicon "${S}"/etc/${PN}-icon.xpm ${PN}.xpm
+
+ domenu "${FILESDIR}"/${PN}.desktop
+}
+
+pkg_postinst() {
+ eselect emacs update ifunset
+ eselect gnuclient update ifunset
+ xdg_desktop_database_update
+
+ einfo "If you are upgrading from XEmacs 21.4 you should note the following"
+ einfo "incompatibilities:"
+ einfo "- Mule-UCS is no longer supported due to proper UTF-8 support in XEmacs 21.5"
+ einfo "- The X resource class has changed from Emacs to XEmacs,"
+ einfo " settings in your .Xdefaults file should be updated accordingly."
+
+ if use xft;
+ then
+ einfo "You have enabled Xft font support. Xft requires font names to be provided"
+ einfo "in a different way, so you may need to adjust your .Xdefaults accordingly."
+ fi
+}
+
+pkg_postrm() {
+ eselect emacs update ifunset
+ eselect gnuclient update ifunset
+ xdg_desktop_database_update
+}