summaryrefslogtreecommitdiff
path: root/app-editors/wxhexeditor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-17 00:09:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-17 00:09:46 +0100
commit74e526c590f52d24a213e25f77858ae0b34ec2c8 (patch)
tree0f6f22133ae9cc04958f6df6d39a02d90ffb1aaf /app-editors/wxhexeditor
parent0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (diff)
gentoo auto-resync : 17:06:2024 - 00:09:46
Diffstat (limited to 'app-editors/wxhexeditor')
-rw-r--r--app-editors/wxhexeditor/Manifest2
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch31
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild48
3 files changed, 81 insertions, 0 deletions
diff --git a/app-editors/wxhexeditor/Manifest b/app-editors/wxhexeditor/Manifest
index 96ffdcb0a29d..7ca0aeb38610 100644
--- a/app-editors/wxhexeditor/Manifest
+++ b/app-editors/wxhexeditor/Manifest
@@ -1,5 +1,7 @@
AUX wxhexeditor-0.24-desktop.patch 613 BLAKE2B c923a7f2782f5f88321d1f86ab75c7a4b05d167d86ece484a01b4e26fa76ad8484d19e5dbe337766ff3de6f8537263d17d810b3a5d9d62b883d5eb07238d0155 SHA512 f542918c3f42546b21bce165853f54ca166d0d8335f948c5d442eb7710d4a1f403d5dc4260b238ce6cfd692d37bad101a4fc6bc83742712ed247bf5477662685
AUX wxhexeditor-0.24-syslibs.patch 2458 BLAKE2B 65dc8a710fb33826b5ae9a9ae2b31cdf58e58252aa4be8df37a4e18495faaaee066c95f1b527d91c71b9b38d8123cc1cac91e9e0386a67ed77b0b8e24ad43016 SHA512 658526b38bb3e3313174ac464711ccceb3606e38e6826c62b4dcb5dca79c6ef32c6d7c84e883035572431eebaf0b7e2ace154df406f2338f39aace84d9fe9403
+AUX wxhexeditor-0.24-wx3.2.patch 898 BLAKE2B a0ff53ba358317fcbd7eceb216be149a2082b71f721184779d821001e15bfebf6ea7ed5d4edd2f348d89df65546db94603ca00b0034b06509eb7bbfb40d55437 SHA512 a1bf16898bb4d77737e93c6e4d219eab11ac2d8b150620f9c2a952ebc7bf9db083828545d33b82fe19cc29d811883d5b1539b1619556e75c7c9b814d73426d02
DIST wxHexEditor-v0.24-src.tar.xz 900868 BLAKE2B 6748249d75e7570197a6c78378a8f3109bfa4c72bf32fe63e2abd31734d97fda3d56ecddb52ac5f9a18cc77b2c727f8277688f1bf75ef8f665a3a9cefd1cb8a6 SHA512 8589da169c90cca5abf6ba957d5c5e17e4211123dbdbaf0e04d31757113e7e302d40df58144ec25d431c7c4ce2fa2721b16621d03630ac8b90478c704a8c5b09
EBUILD wxhexeditor-0.24-r2.ebuild 980 BLAKE2B be4ab318b97c5aee2052a90f7ed8f0efe5e97e9e6128714975296069e4c0509a5571bc2cca9b5574d0ffec960dd5714a34b5e8f72d0bdc3658b3100221ec3ce4 SHA512 f0dd672b789e9369d20e56352e760f7731a33aa892e98d5892c817ef96eb11232baa0dd755f51376761e38886ce07f840bf919659c83549826dccb0c9099d9fd
+EBUILD wxhexeditor-0.24-r3.ebuild 1012 BLAKE2B 1ac284e3c96c23aeb1b606ff69fcb4d9270f00f6123a637af08ad47e795aedef56456976886a5d380201f5045858abb436e5f70bf372cae9a8c7d5dd0149ad1d SHA512 334ef02a31f2ba33d1a477b829c4279742977007f1f1c1cc739d43c8899bb649c0dc9a8fa6ea4cbb39b64f225a7b427a11b6f1a7211b89b1afde8ee3fd029427
MISC metadata.xml 410 BLAKE2B ded331534020201d32a277f16c3bca28a711ec74bf09c17b7100ed6e9f92511f60d274b2e9c291209692aa8d083a437b8e6ffb21ed7f7e6a83a5589764b2683c SHA512 d6435dcce58dfea339bc441e05fd88f60dae20bbcc8410311e81b9fca37adc715150b092d660b61a769f746e4eca66d33c9254654526152b314a1a30843639ec
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch
new file mode 100644
index 000000000000..6bbeb2109a56
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.24-wx3.2.patch
@@ -0,0 +1,31 @@
+Description: Fix compatibility with wxWidgets 3.2
+Author: Scott Talbert <swt@techie.net>
+Last-Update: 2022-10-17
+Forwarded: no
+
+--- a/src/HexDialogs.cpp
++++ b/src/HexDialogs.cpp
+@@ -420,7 +420,7 @@ void FindDialog::OnChar( wxKeyEvent& eve
+ }
+
+ void FindDialog::EventHandler( wxCommandEvent& event ){
+- WX_CLEAR_ARRAY(parent->HighlightArray )
++ WX_CLEAR_ARRAY(parent->HighlightArray );
+ parent->HighlightArray.Shrink();
+
+ if( event.GetId() == btnFind->GetId())
+--- a/src/HexEditorCtrl/HexEditorCtrl.cpp
++++ b/src/HexEditorCtrl/HexEditorCtrl.cpp
+@@ -64,9 +64,9 @@ HexEditorCtrl::~HexEditorCtrl( void ){
+ Dynamic_Disconnector();
+ Clear();
+
+- WX_CLEAR_ARRAY(MainTagArray)
+- WX_CLEAR_ARRAY(HighlightArray)
+- WX_CLEAR_ARRAY(CompareArray)
++ WX_CLEAR_ARRAY(MainTagArray);
++ WX_CLEAR_ARRAY(HighlightArray);
++ WX_CLEAR_ARRAY(CompareArray);
+
+ MainTagArray.Shrink();
+ HighlightArray.Shrink();
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild
new file mode 100644
index 000000000000..40e10aaf5241
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.24-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="wxHexEditor"
+WX_GTK_VER=3.2-gtk3
+inherit flag-o-matic toolchain-funcs wxwidgets
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files"
+HOMEPAGE="https://github.com/EUA/wxHexEditor"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-v${PV}-src.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ app-crypt/mhash
+ dev-libs/udis86
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-syslibs.patch
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-wx3.2.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/854414
+ # https://github.com/EUA/wxHexEditor/issues/222
+ filter-lto
+}