summaryrefslogtreecommitdiff
path: root/app-editors/vis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
commit4ead5818a5d230bcc875202c487761a9b786e945 (patch)
tree63238d1977f2788cb5b7074037f15810af25bb88 /app-editors/vis
parentd074d0ba59e3121dba0c27c4a18f1e481f67b62a (diff)
gentoo auto-resync : 04:12:2023 - 10:56:18
Diffstat (limited to 'app-editors/vis')
-rw-r--r--app-editors/vis/Manifest3
-rw-r--r--app-editors/vis/vis-0.8-r1.ebuild96
-rw-r--r--app-editors/vis/vis-9999.ebuild12
3 files changed, 106 insertions, 5 deletions
diff --git a/app-editors/vis/Manifest b/app-editors/vis/Manifest
index 5b669c0eab1f..9aa0f2b56f0b 100644
--- a/app-editors/vis/Manifest
+++ b/app-editors/vis/Manifest
@@ -1,5 +1,6 @@
DIST vis-0.8.tar.gz 404496 BLAKE2B eafb7098a6c8e0d8f277be66984d5fd298ac86d524a4219a7d7730599157ca68c040615622cd1680b101e1cd003eba03343496762d0d4dc2766a079116f21eea SHA512 ab4eda075034955411bdbc0ade2fe9149a48c644fa2f70add8d3b9d749f86b98a4e429745b5cae7fdbc0a1e07c8587539a055cd1c6734bb59e43c580c949e0aa
DIST vis-test-0.5.tar.gz 99314 BLAKE2B 988d7e93d0f3c58d2fc8fbe9293049c6a3cc44dfcbfbd4f42f7992815cf33a604340b59171dcd880f7180ae56e3f73f46684b7aacd96438480db6c4592851f2c SHA512 c41b40f23a45a7ebd9c16aa853d9c3b517767cb88ff8dc268da44276a02aa8c77de0fc6aa243a1e4cdfbc27182870b82d0b9bc892bb87ea74d5275d76c554ed1
+EBUILD vis-0.8-r1.ebuild 2463 BLAKE2B 410b8cc3c72f083f2be43066c865f148e09d4e408ba9529dcb43180c887e529319786352b4a6febe28e55161d3adc3e9591abe40fa278a8ac56b4feed7fc3bd4 SHA512 6ed6299d132d75a1542649be5a4c2186aabad379c0a7faa61ba985bdc89b2a81ce030f4ae0e3c5ad76f83784304d70b30f7756e2bc28f25ee73c272b2458f7f6
EBUILD vis-0.8.ebuild 2436 BLAKE2B 09be5fd7ef0a9f508dad901ae30551aaad0656de622e3f891479ee06cbbfd1b78de67a4d437a00cfa06cffd2c7b0c1d5e6002053af6bcd6691295f61434d6e10 SHA512 d51a0296a2c99a03c10da49dc11c4da0cc0dfeab605fef7e43724cd18bc4a607992f7365cbef13a35cc95994ea11978e29e45ae957b9ae1e8156aa1785b6f7f9
-EBUILD vis-9999.ebuild 2439 BLAKE2B 52ba2a22d49d88c1ed01c59fe9eb59eb74a10d4a9e76af1ec0cbd29fc09aeaba46d4b90f809f79f6861635bfcadbdbede83f1e0920dd6cff21ad9eff67de1e38 SHA512 57202fab886d7907a168a7354e90a18a92217a40341d07eb0dae87e52dd82c5d6e8b455f27aea933860b1ad2c80c737f334fd4a275fa72ddb737544a8e896692
+EBUILD vis-9999.ebuild 2463 BLAKE2B 410b8cc3c72f083f2be43066c865f148e09d4e408ba9529dcb43180c887e529319786352b4a6febe28e55161d3adc3e9591abe40fa278a8ac56b4feed7fc3bd4 SHA512 6ed6299d132d75a1542649be5a4c2186aabad379c0a7faa61ba985bdc89b2a81ce030f4ae0e3c5ad76f83784304d70b30f7756e2bc28f25ee73c272b2458f7f6
MISC metadata.xml 698 BLAKE2B d09b6b1784d0845c80f097b0a3d27ed58a6ff4193c424ee856e1ec815aedecac8a480507e17046d4145cd0e20213b2165a8986c54bd4b3614f7cb30136e37508 SHA512 16134efe8760a57af6fcdd8adc93173d2a65e3f88d7b701b12a691b9899aaee341716fe29e2d7a89f3dc48ef127c736e63df7bdd586363023ce6a00f048f8864
diff --git a/app-editors/vis/vis-0.8-r1.ebuild b/app-editors/vis/vis-0.8-r1.ebuild
new file mode 100644
index 000000000000..09bd443398c8
--- /dev/null
+++ b/app-editors/vis/vis-0.8-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PTV=0.5
+LUA_COMPAT=( lua5-2 lua5-3 lua5-4 )
+
+inherit lua-single
+
+if [ "${PV}" == "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martanne/vis.git"
+else
+ SRC_URI="https://github.com/martanne/vis/releases/download/v${PV}/${P}.tar.gz
+ test? ( https://github.com/martanne/vis-test/releases/download/v${MY_PTV}/vis-test-${MY_PTV}.tar.gz )"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+fi
+
+DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
+HOMEPAGE="https://github.com/martanne/vis"
+LICENSE="ISC MIT"
+SLOT="0"
+IUSE="+ncurses +lua selinux test tre"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# - Known to also work with NetBSD curses
+DEPEND="dev-libs/libtermkey
+ sys-apps/acl
+ ncurses? ( sys-libs/ncurses:0= )
+ lua? ( ${LUA_DEPS} )
+ tre? ( dev-libs/tre )"
+RDEPEND="${DEPEND}
+ app-eselect/eselect-vi
+ lua? (
+ $(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]')
+ )
+"
+# lpeg: https://github.com/martanne/vis-test/issues/28
+BDEPEND="test? (
+ $(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
+)"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ if use test; then
+ if [ ! "${PV}" == "9999" ]; then
+ rm -r test || die
+ mv "${WORKDIR}/vis-test-${MY_PTV}" test || die
+ fi
+
+ # https://bugs.gentoo.org/722014 https://github.com/martanne/vis-test/pull/22
+ sed -i 's;./ccan-config > config.h;./ccan-config "${CC}" ${CFLAGS} > config.h;' test/core/Makefile || die
+
+ # https://github.com/martanne/vis-test/pull/29
+ sed -i 's;cpp -P;${CPP:-cpp} -P;' test/vim/test.sh || die
+
+ # https://github.com/martanne/vis-test/issues/27 a Werror clone
+ sed -i 's;|| strstr(output, "warning");;' test/core/ccan-config.c || die
+ fi
+
+ sed -i 's|STRIP?=.*|STRIP=true|' Makefile || die
+ sed -i 's|${DOCPREFIX}/vis|${DOCPREFIX}|' Makefile || die
+ sed -i 's|DOCUMENTATION = LICENSE|DOCUMENTATION =|' Makefile || die
+
+ default
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-lpeg-static \
+ $(use_enable lua) \
+ $(use_enable ncurses curses) \
+ $(use_enable selinux) \
+ $(use_enable tre) || die
+}
+
+update_symlinks() {
+ einfo "Calling eselect vi update --if-unset"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ update_symlinks
+}
+
+pkg_postinst() {
+ update_symlinks
+}
diff --git a/app-editors/vis/vis-9999.ebuild b/app-editors/vis/vis-9999.ebuild
index 34f57c01387b..09bd443398c8 100644
--- a/app-editors/vis/vis-9999.ebuild
+++ b/app-editors/vis/vis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
MY_PTV=0.5
LUA_COMPAT=( lua5-2 lua5-3 lua5-4 )
-inherit lua-single optfeature
+inherit lua-single
if [ "${PV}" == "9999" ]; then
inherit git-r3
@@ -32,7 +32,11 @@ DEPEND="dev-libs/libtermkey
lua? ( ${LUA_DEPS} )
tre? ( dev-libs/tre )"
RDEPEND="${DEPEND}
- app-eselect/eselect-vi"
+ app-eselect/eselect-vi
+ lua? (
+ $(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]')
+ )
+"
# lpeg: https://github.com/martanne/vis-test/issues/28
BDEPEND="test? (
$(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]')
@@ -71,6 +75,7 @@ src_configure() {
./configure \
--prefix="${EPREFIX}"/usr \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-lpeg-static \
$(use_enable lua) \
$(use_enable ncurses curses) \
$(use_enable selinux) \
@@ -88,5 +93,4 @@ pkg_postrm() {
pkg_postinst() {
update_symlinks
- optfeature "syntax highlighting support" dev-lua/lpeg
}