summaryrefslogtreecommitdiff
path: root/app-editors/tea
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /app-editors/tea
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/Manifest4
-rw-r--r--app-editors/tea/metadata.xml1
-rw-r--r--app-editors/tea/tea-44.1.1.ebuild65
3 files changed, 69 insertions, 1 deletions
diff --git a/app-editors/tea/Manifest b/app-editors/tea/Manifest
index 8a788e6e6faa..d1c3ae793b4b 100644
--- a/app-editors/tea/Manifest
+++ b/app-editors/tea/Manifest
@@ -1,3 +1,5 @@
DIST tea-44.1.0.tar.bz2 402335 BLAKE2B 3c3191d6fdcd0e0c73ba408e3219a65d28d2950ebba905a003555fb1ceebeb6ce8dc6448762267e981e429fb0513d21d49b8b25fc7881daaded5f04034cf1ff6 SHA512 a430ed6d23d828b12235f61ad3d37f36c28754dcde8ac6d382a251f4b21cc253d70adab96814ee2d31fd6e92d4b5fbc941386b6d485716020800b5fa5e71b194
+DIST tea-44.1.1.tar.bz2 425326 BLAKE2B e674456c428bbecd5afb256280bccb61b6385492153955625c158dcfebba0ed31caebdcc06bc1f809517badddef3d97245a4bc873bcc0593957647becdebf62b SHA512 fc7bf6f76ac3a48767a39ff5bcada4c7dae40950bfd9aca4021b3581e1b702c73f2608b070306dd528932d5eaa73bf01632a4376bbb71deaf1189a0f790c05a9
EBUILD tea-44.1.0.ebuild 1197 BLAKE2B 8a2888e9731ea63681999f14478e8735e0f8c24bc984f5b32bd59fde2a8c2928e01388681ed053e04226be9f3a40bf9f3132102398a520743a6e5da963380667 SHA512 9551d92fad6d8660660a668b8ec68adf462f70123aba3499958e510f7e45f9a2bd263b21014551444d8f5203aa83aa4b718f6bcc9f226f6729613d1620b4faea
-MISC metadata.xml 674 BLAKE2B e17e1abc3f9aed5ff537c5abd0fe5a1f61fc6c399a184422bb0d57e6bd455b1ac766f7832d0c53daab8bf8ad7b055ec7231fd3499efa612cd43ce205f33684be SHA512 379863b99aabcfba9d22a9bd946605bbb530c7c29baf5744d5a0de82369146f63faf57e36adf87a16bfc37dfdbbd1883822fdafd3627e775eb872fa20048bc1a
+EBUILD tea-44.1.1.ebuild 1368 BLAKE2B 947d536f6aa0ef71a5f516d051c11f57bfb99c63fdaed4a244536dd300f0b798e7173235eaa7490c6e6c6a68f3cea6dab63c9042ada6e60440618f081f8cfae8 SHA512 feafc17ffbdb6e6943020d83096f63e0fa5f8a0d41b28f00bd7ce12ba41d99f989b89c8b1b0b15990ac0d6ffe20f907e2a2e99433b0f109ceb66f72105bf461d
+MISC metadata.xml 737 BLAKE2B 891e84e0d4bef855f64e09d795bb57c8dbac9906529d311716047b2aabd08f1ec93a28d0f61652a5d7af21fae8ac8e920bca68492ddc79db6e3d0d02d091b2cf SHA512 f253f80583e79be7b0e03ec3515e2e1e48425fd7bb520422e0c2883fc2da07b7e1b5f83d6c7d4e6317a47b2179f7627b8975493b82e800241530aa2b42efd6a6
diff --git a/app-editors/tea/metadata.xml b/app-editors/tea/metadata.xml
index 86348fa600a3..a3b87502efe6 100644
--- a/app-editors/tea/metadata.xml
+++ b/app-editors/tea/metadata.xml
@@ -13,5 +13,6 @@
<use>
<flag name="aspell">Enable spellchecking using <pkg>app-text/aspell</pkg></flag>
<flag name="hunspell">Enable spellchecking using <pkg>app-text/hunspell</pkg></flag>
+ <flag name="qml">Enable support for plugins using QML</flag>
</use>
</pkgmetadata>
diff --git a/app-editors/tea/tea-44.1.1.ebuild b/app-editors/tea/tea-44.1.1.ebuild
new file mode 100644
index 000000000000..f11b523d5d22
--- /dev/null
+++ b/app-editors/tea/tea-44.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="https://tea.ourproject.org/"
+SRC_URI="https://tea.ourproject.org/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="aspell djvu hunspell pdf +qml"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ aspell? ( app-text/aspell )
+ djvu? ( app-text/djvu )
+ hunspell? ( app-text/hunspell:= )
+ pdf? ( app-text/poppler[qt5] )
+ qml? ( dev-qt/qtdeclarative:5 )
+"
+DEPEND="${RDEPEND}
+ hunspell? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS-RU TODO )
+
+src_configure() {
+ eqmake5 src.pro \
+ PREFIX="/usr" \
+ $(use aspell || echo CONFIG+=noaspell) \
+ $(use djvu && echo CONFIG+=usedjvu) \
+ $(use hunspell || echo CONFIG+=nohunspell) \
+ $(use pdf && echo CONFIG+=usepoppler) \
+ $(use qml || echo CONFIG+=noqml)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ docinto html
+ dodoc manuals/*.html
+
+ insinto /usr/share/qt5/translations
+ doins translations/${PN}_*.qm
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}