summaryrefslogtreecommitdiff
path: root/app-editors/retext/retext-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /app-editors/retext/retext-9999.ebuild
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'app-editors/retext/retext-9999.ebuild')
-rw-r--r--app-editors/retext/retext-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 413cc5d08d66..cf7bf4d8be84 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -37,12 +37,12 @@ RDEPEND="
>=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/python-markdown-math[${PYTHON_USEDEP}]
- dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-qt/linguist-tools
- test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )
+ test? ( dev-python/PyQt6[testlib,${PYTHON_USEDEP}] )
"
distutils_enable_tests unittest
@@ -57,7 +57,7 @@ src_test() {
}
python_test() {
- eunittest || die
+ virtx eunittest
}
pkg_postinst() {
@@ -65,7 +65,7 @@ pkg_postinst() {
optfeature "dictionary support" dev-python/pyenchant
# See https://bugs.gentoo.org/772197.
- optfeature "rendering with webengine" dev-python/PyQtWebEngine
+ optfeature "rendering with webengine" dev-python/PyQt6-WebEngine
einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."