summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /app-editors/neovim/neovim-9999.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild42
1 files changed, 27 insertions, 15 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index ae758e6e27bd..38e9b6a6c5bc 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit cmake optfeature xdg
+LUA_COMPAT=( lua5-{1..2} luajit )
+
+inherit cmake lua-single optfeature xdg
DESCRIPTION="Vim-fork focused on extensibility and agility."
HOMEPAGE="https://neovim.io"
@@ -18,34 +20,38 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +luajit +nvimpager +tui"
+IUSE="+lto +nvimpager +tui"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-#REQUIRED_USE="test? ( luajit )"
+#REQUIRED_USE="test? ( lua_single_target_luajit )"
#RESTRICT="!test? ( test )"
-BDEPEND="
+# Upstream build scripts invoke the Lua interpreter
+BDEPEND="${LUA_DEPS}
dev-util/gperf
virtual/libiconv
virtual/libintl
virtual/pkgconfig
"
-# Once dev-lua/busted has luajit support, we can add tests.
+# TODO: add tests, dev-lua/busted has now got luajit support.
# bug #584694
-DEPEND="
+DEPEND="${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ dev-lua/lpeg[${LUA_USEDEP}]
+ dev-lua/luv[${LUA_USEDEP}]
+ dev-lua/mpack[${LUA_USEDEP}]
+ ')
+ $(lua_gen_cond_dep '
+ dev-lua/LuaBitOp[${LUA_USEDEP}]
+ ' lua5-{1,2})
dev-libs/libutf8proc:=
dev-libs/libuv:0=
>=dev-libs/libvterm-0.1.2
dev-libs/msgpack:0=
- dev-lua/lpeg[luajit=]
- dev-lua/luv[luajit=]
- dev-lua/mpack[luajit=]
+ dev-libs/tree-sitter:=
net-libs/libnsl
- luajit? ( dev-lang/luajit:2 )
- !luajit? (
- dev-lang/lua:=
- dev-lua/LuaBitOp
- )
tui? (
dev-libs/libtermkey
>=dev-libs/unibilium-2.0.0:0=
@@ -56,6 +62,11 @@ RDEPEND="
app-eselect/eselect-vi
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.4-cmake_lua_version.patch
+ "${FILESDIR}"/${PN}-0.4.4-cmake_multiimpl_luv.patch
+)
+
src_prepare() {
# use our system vim dir
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
@@ -73,7 +84,8 @@ src_configure() {
local mycmakeargs=(
-DENABLE_LTO=$(usex lto)
-DFEAT_TUI=$(usex tui)
- -DPREFER_LUA=$(usex luajit no yes)
+ -DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
+ -DLUA_PRG="${ELUA}"
)
cmake_src_configure
}