summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /app-editors/neovim/neovim-9999.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 6944c0791a40..ae758e6e27bd 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -13,12 +13,16 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+luajit +nvimpager +tui"
+IUSE="+lto +luajit +nvimpager +tui"
+# Upstream say the test library needs LuaJIT
+# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
+#REQUIRED_USE="test? ( luajit )"
+#RESTRICT="!test? ( test )"
BDEPEND="
dev-util/gperf
@@ -26,11 +30,12 @@ BDEPEND="
virtual/libintl
virtual/pkgconfig
"
-
+# Once dev-lua/busted has luajit support, we can add tests.
+# bug #584694
DEPEND="
dev-libs/libutf8proc:=
dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1
+ >=dev-libs/libvterm-0.1.2
dev-libs/msgpack:0=
dev-lua/lpeg[luajit=]
dev-lua/luv[luajit=]
@@ -46,14 +51,11 @@ DEPEND="
>=dev-libs/unibilium-2.0.0:0=
)
"
-
RDEPEND="
${DEPEND}
app-eselect/eselect-vi
"
-CMAKE_BUILD_TYPE=Release
-
src_prepare() {
# use our system vim dir
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
@@ -63,7 +65,13 @@ src_prepare() {
}
src_configure() {
+ # Upstream default to LTO on non-debug builds
+ # Let's expose it as a USE flag because upstream
+ # have preferences for how we should use LTO
+ # if we want it on (not just -flto)
+ # ... but allow turning it off.
local mycmakeargs=(
+ -DENABLE_LTO=$(usex lto)
-DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex luajit no yes)
)