summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /app-editors/neovim/neovim-9999.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index d8873b59f067..99aa8bbbb72f 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
fi
LICENSE="Apache-2.0 vim"
@@ -46,12 +46,10 @@ DEPEND="${LUA_DEPS}
$(lua_gen_cond_dep '
dev-lua/LuaBitOp[${LUA_USEDEP}]
' lua5-{1,2})
- dev-libs/libutf8proc:=
dev-libs/libuv:0=
>=dev-libs/libvterm-0.1.2
dev-libs/msgpack:0=
dev-libs/tree-sitter:=
- net-libs/libnsl
tui? (
dev-libs/libtermkey
>=dev-libs/unibilium-2.0.0:0=
@@ -65,6 +63,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
"${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-0.4.4-cmake-darwin.patch"
)
src_prepare() {
@@ -81,6 +80,7 @@ src_configure() {
# have preferences for how we should use LTO
# if we want it on (not just -flto)
# ... but allow turning it off.
+ # TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
-DENABLE_LTO=$(usex lto)
-DFEAT_TUI=$(usex tui)