summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 03:13:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 03:13:19 +0000
commit1f709ed82b8014b4c156f87c66cee7d0d1d3905d (patch)
treee2a478d1bbdb4f68ce4d30908ca0e21ca984a602 /app-editors/neovim/files
parent924750a8c767b278c9870be5dcfedced436f1276 (diff)
gentoo auto-resync : 04:11:2022 - 03:13:18
Diffstat (limited to 'app-editors/neovim/files')
-rw-r--r--app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch (renamed from app-editors/neovim/files/neovim-9999-cmake-release-type.patch)22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
index 8c24b6b6123f..8114e2a92b74 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
+++ b/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
@@ -1,16 +1,16 @@
Ensure that :checkhealth is happy with the Gentoo build type.
https://bugs.gentoo.org/757744
---- a/runtime/lua/nvim/health.lua
-+++ b/runtime/lua/nvim/health.lua
-@@ -149,7 +149,7 @@ local function check_performance()
- let s:buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(s:buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(s:buildtype)
- else
- call health#report_info(s:buildtype)
+--- a/runtime/autoload/health/nvim.vim
++++ b/runtime/autoload/health/nvim.vim
+@@ -135,7 +135,7 @@ function! s:check_performance() abort
+ let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
+ if empty(buildtype)
+ call health#report_error('failed to get build type from :version')
+- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
++ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
+ call health#report_ok(buildtype)
+ else
+ call health#report_info(buildtype)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,12 +137,6 @@ else()