summaryrefslogtreecommitdiff
path: root/app-editors/ne/ne-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-editors/ne/ne-3.3.1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-editors/ne/ne-3.3.1.ebuild')
-rw-r--r--app-editors/ne/ne-3.3.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/ne/ne-3.3.1.ebuild b/app-editors/ne/ne-3.3.1.ebuild
new file mode 100644
index 000000000000..242892b33de8
--- /dev/null
+++ b/app-editors/ne/ne-3.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="https://ne.di.unimi.it/"
+SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="sys-libs/ncurses:="
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+HTML_DOCS=( doc/html/. )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.1-respect-CFLAGS.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's/-O3//' src/makefile || die
+}
+
+src_configure() {
+ # bug #776799
+ sed -i -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" src/makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c11
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/${PN}" \
+ OPTS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ "${PN}"
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /usr/share/${PN}/syntax
+ doins syntax/*.jsf
+
+ doman doc/${PN}.1
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}