summaryrefslogtreecommitdiff
path: root/app-editors/ne/ne-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /app-editors/ne/ne-3.3.0.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'app-editors/ne/ne-3.3.0.ebuild')
-rw-r--r--app-editors/ne/ne-3.3.0.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/app-editors/ne/ne-3.3.0.ebuild b/app-editors/ne/ne-3.3.0.ebuild
index c1c60d57ba1e..87aaff065bf8 100644
--- a/app-editors/ne/ne-3.3.0.ebuild
+++ b/app-editors/ne/ne-3.3.0.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
-DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
-HOMEPAGE="http://ne.di.unimi.it/"
-SRC_URI="http://ne.di.unimi.it/${P}.tar.gz"
+DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="https://ne.di.unimi.it/"
+SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="sys-libs/ncurses:0=[tinfo]"
+BDEPEND="virtual/pkgconfig"
+DEPEND="sys-libs/ncurses:="
RDEPEND="
${DEPEND}
dev-lang/perl
@@ -25,8 +24,13 @@ HTML_DOCS=( doc/html/. )
src_prepare() {
default
- #sed -i -e 's/-O3//' src/makefile || die
- sed -i -e "s|-lcurses|-ltinfo|g" src/makefile || die
+
+ sed -i -e 's/-O3//' src/makefile || die
+}
+
+src_configure() {
+ # bug #776799
+ sed -i -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" src/makefile || die
}
src_compile() {