summaryrefslogtreecommitdiff
path: root/app-editors/ne/ne-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-editors/ne/ne-3.3.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-editors/ne/ne-3.3.0.ebuild')
-rw-r--r--app-editors/ne/ne-3.3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/ne/ne-3.3.0.ebuild b/app-editors/ne/ne-3.3.0.ebuild
new file mode 100644
index 000000000000..f90eeb484b77
--- /dev/null
+++ b/app-editors/ne/ne-3.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="http://ne.di.unimi.it/"
+SRC_URI="http://ne.di.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0=[tinfo]"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+HTML_DOCS=( doc/html/. )
+
+src_prepare() {
+ default
+ #sed -i -e 's/-O3//' src/makefile || die
+ sed -i -e "s|-lcurses|-ltinfo|g" src/makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c11
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/${PN}" \
+ OPTS="${CFLAGS}" \
+ "${PN}"
+}
+
+src_install() {
+ dobin "src/${PN}"
+
+ insinto "/usr/share/${PN}/syntax"
+ doins syntax/*.jsf
+
+ doman "doc/${PN}.1"
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}