summaryrefslogtreecommitdiff
path: root/app-editors/levee/levee-3.5a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/levee/levee-3.5a.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/levee/levee-3.5a.ebuild')
-rw-r--r--app-editors/levee/levee-3.5a.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/levee/levee-3.5a.ebuild b/app-editors/levee/levee-3.5a.ebuild
new file mode 100644
index 000000000000..965d248fd053
--- /dev/null
+++ b/app-editors/levee/levee-3.5a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Really tiny vi clone, for things like rescue disks"
+HOMEPAGE="http://www.pell.chi.il.us/~orc/Code/"
+SRC_URI="http://www.pell.chi.il.us/~orc/Code/levee/${P}.tar.gz"
+
+LICENSE="levee"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="!app-text/lv
+ sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4o-darwin.patch
+ epatch "${FILESDIR}"/${P}-QA.patch
+ epatch "${FILESDIR}"/${PN}-3.5-glibc210.patch
+}
+
+src_configure() {
+ export AC_CPP_PROG=$(tc-getCPP)
+ export AC_PATH=${PATH}
+ export AC_LIBDIR="$($(tc-getPKG_CONFIG) --libs ncurses)"
+ ./configure.sh --prefix="${PREFIX}"/usr || die "configure failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -Wextra ${LDFLAGS}" CC=$(tc-getCC)
+}
+
+src_install() {
+ emake PREFIX="${D}${EPREFIX}" install
+}