summaryrefslogtreecommitdiff
path: root/app-editors/kakoune/kakoune-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/kakoune/kakoune-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/kakoune/kakoune-9999.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-9999.ebuild b/app-editors/kakoune/kakoune-9999.ebuild
new file mode 100644
index 000000000000..f083c66b5e3e
--- /dev/null
+++ b/app-editors/kakoune/kakoune-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs git-r3 versionator
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://github.com/mawww/kakoune"
+EGIT_REPO_URI="https://github.com/mawww/kakoune.git"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug static"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]
+"
+DEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-gcc && ! version_is_at_least 5.0 $(gcc-version); then
+ die "Clang or GCC >=5.0 is required to build this version"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i -e '/CXXFLAGS += -O3/d' src/Makefile || \
+ die "Failed to patch makefile"
+}
+
+src_configure() {
+ tc-export CXX
+ export debug=$(usex debug)
+ export static=$(usex static)
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" PREFIX="${EPREFIX}/usr" docdir="${ED%/}/usr/share/doc/${PF}" install
+}