summaryrefslogtreecommitdiff
path: root/app-editors/kakoune/kakoune-2022.10.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 18:51:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 18:51:10 +0000
commitaa44121f587698ace480d5ca16ae9e64fe1b4d0b (patch)
tree51e169f07cbed2c1aca51f5e6ae3152233d68f27 /app-editors/kakoune/kakoune-2022.10.31.ebuild
parent7d58bf45ea7b2d8f188fd2aa40484a8c9a3381a7 (diff)
gentoo auto-resync : 14:11:2022 - 18:51:10
Diffstat (limited to 'app-editors/kakoune/kakoune-2022.10.31.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2022.10.31.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2022.10.31.ebuild b/app-editors/kakoune/kakoune-2022.10.31.ebuild
new file mode 100644
index 000000000000..2e6ad9d352ed
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2022.10.31.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ sed -i '/CXXFLAGS += -O3/d' src/Makefile || die
+ default
+}
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake -C src all
+}
+
+src_test() {
+ emake -C src test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install
+
+ rm "${ED}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}