summaryrefslogtreecommitdiff
path: root/app-editors/hyx/hyx-2021.06.09.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /app-editors/hyx/hyx-2021.06.09.ebuild
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'app-editors/hyx/hyx-2021.06.09.ebuild')
-rw-r--r--app-editors/hyx/hyx-2021.06.09.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/hyx/hyx-2021.06.09.ebuild b/app-editors/hyx/hyx-2021.06.09.ebuild
new file mode 100644
index 000000000000..d185af4b0b5f
--- /dev/null
+++ b/app-editors/hyx/hyx-2021.06.09.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalistic console hex editor with vim-like controls"
+HOMEPAGE="https://yx7.cc/code/"
+SRC_URI="https://yx7.cc/code/hyx/${P}.tar.xz"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # Avoid complaining about not respecting LDFLAGS
+ "${FILESDIR}/${PN}-ldflags.patch"
+)
+
+src_compile() {
+ CC=$(tc-getCC) emake
+}
+
+src_install() {
+ dobin hyx
+}