summaryrefslogtreecommitdiff
path: root/app-editors/hteditor/hteditor-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /app-editors/hteditor/hteditor-2.1.0.ebuild
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'app-editors/hteditor/hteditor-2.1.0.ebuild')
-rw-r--r--app-editors/hteditor/hteditor-2.1.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-editors/hteditor/hteditor-2.1.0.ebuild b/app-editors/hteditor/hteditor-2.1.0.ebuild
index a38ef31072d0..5e5d0e083085 100644
--- a/app-editors/hteditor/hteditor-2.1.0.ebuild
+++ b/app-editors/hteditor/hteditor-2.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
MY_P=${P/editor}
@@ -27,7 +27,15 @@ DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
S=${WORKDIR}/${MY_P}
-PATCHES=("${FILESDIR}"/${P}-gcc-7.patch)
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-7.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \