summaryrefslogtreecommitdiff
path: root/app-editors/gvim/gvim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
commitfe618c8b8c934661d2297b2aeb0615a48e787691 (patch)
tree24a8209687e0ff34205acd703b6b80e7c6897f81 /app-editors/gvim/gvim-9999.ebuild
parent1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (diff)
gentoo auto-resync : 27:07:2022 - 03:00:38
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild43
1 files changed, 8 insertions, 35 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 99018e02a288..aaab6e09d27d 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -29,10 +29,11 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
LICENSE="vim"
SLOT="0"
-IUSE="acl aqua crypt cscope debug gtk gtk2 lua motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl aqua crypt cscope debug lua motif netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
+ aqua? ( !motif )
"
RDEPEND="
@@ -45,23 +46,11 @@ RDEPEND="
x11-libs/libXt
acl? ( kernel_linux? ( sys-apps/acl ) )
!aqua? (
- gtk? (
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
x11-libs/gtk+:3
x11-libs/libXft
)
- !gtk? (
- gtk2? (
- >=x11-libs/gtk+-2.6:2
- x11-libs/libXft
- )
- !gtk2? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- neXt? ( x11-libs/neXtaw )
- !neXt? ( x11-libs/libXaw )
- )
- )
- )
)
crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
@@ -227,13 +216,7 @@ src_configure() {
)
fi
- # gvim's GUI preference order is as follows:
- # aqua CARBON (not tested)
- # -aqua gtk GTK3
- # -aqua -gtk gtk2 GTK2
- # -aqua -gtk -gtk motif MOTIF
- # -aqua -gtk -gtk -motif neXt NEXTAW
- # -aqua -gtk -gtk -motif -neXt ATHENA
+ # Default is gtk unless aqua or motif are enabled
echo ; echo
if use aqua; then
einfo "Building gvim with the Carbon GUI"
@@ -241,23 +224,13 @@ src_configure() {
--enable-darwin
--enable-gui=carbon
)
- elif use gtk; then
- myconf+=( --enable-gtk3-check )
- einfo "Building gvim with the gtk+-3 GUI"
- myconf+=( --enable-gui=gtk3 )
- elif use gtk2; then
- myconf+=( --enable-gtk2-check )
- einfo "Building gvim with the gtk+-2 GUI"
- myconf+=( --enable-gui=gtk2 )
elif use motif; then
einfo "Building gvim with the MOTIF GUI"
myconf+=( --enable-gui=motif )
- elif use neXt; then
- einfo "Building gvim with the neXtaw GUI"
- myconf+=( --enable-gui=nextaw )
else
- einfo "Building gvim with the Athena GUI"
- myconf+=( --enable-gui=athena )
+ myconf+=( --enable-gtk3-check )
+ einfo "Building gvim with the gtk+-3 GUI"
+ myconf+=( --enable-gui=gtk3 )
fi
echo ; echo