summaryrefslogtreecommitdiff
path: root/app-editors/gvim/gvim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-editors/gvim/gvim-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index a26105139406..2bdfc5eb2348 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-VIM_VERSION="8.1"
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+EAPI=7
+VIM_VERSION="8.2"
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby24 ruby25 ruby26"
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-inherit vim-doc flag-o-matic xdg-utils gnome2-utils bash-completion-r1 prefix python-single-r1 ruby-single
+inherit vim-doc flag-o-matic xdg-utils bash-completion-r1 prefix python-single-r1 ruby-single
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -199,9 +199,7 @@ src_configure() {
$(use_enable netbeans)
$(use_enable nls)
$(use_enable perl perlinterp)
- $(use_enable python pythoninterp)
$(use_enable python python3interp)
- $(use_with python python-command $(type -P $(eselect python show --python2)))
$(use_with python python3-command $(type -P $(eselect python show --python3)))
$(use_enable racket mzschemeinterp)
$(use_enable ruby rubyinterp)
@@ -341,29 +339,29 @@ src_install() {
}
pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
+ # update documentation tags (from vim-doc.eclass)
update_vim_helptags
- # Update fdo mime stuff, bug #78394
+ # update fdo mime stuff, bug #78394
xdg_desktop_database_update
- # Update icon cache
- gnome2_icon_cache_update
+ # update icon cache
+ xdg_icon_cache_update
- # Call eselect vi update
+ # call eselect vi update
eselect_vi_update
}
pkg_postrm() {
- # Update documentation tags (from vim-doc.eclass)
+ # update documentation tags (from vim-doc.eclass)
update_vim_helptags
- # Update fdo mime stuff, bug #78394
+ # update fdo mime stuff, bug #78394
xdg_desktop_database_update
- # Update icon cache
- gnome2_icon_cache_update
+ # update icon cache
+ xdg_icon_cache_update
- # Call eselect vi update
+ # call eselect vi update
eselect_vi_update
}