summaryrefslogtreecommitdiff
path: root/app-editors/ghostwriter/ghostwriter-24.02.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
commit3a6d209caa07e3be8e8423251b70c8bbeeedb17f (patch)
treeaa94c255fa1bd982214ca518fb93d674cc253101 /app-editors/ghostwriter/ghostwriter-24.02.2.ebuild
parent1f43daba2fbe6f53e67c63944941dc645657c5b3 (diff)
gentoo auto-resync : 12:04:2024 - 00:33:28
Diffstat (limited to 'app-editors/ghostwriter/ghostwriter-24.02.2.ebuild')
-rw-r--r--app-editors/ghostwriter/ghostwriter-24.02.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/ghostwriter-24.02.2.ebuild b/app-editors/ghostwriter/ghostwriter-24.02.2.ebuild
new file mode 100644
index 000000000000..5742655537f8
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-24.02.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="office"
+ECM_HANDBOOK="optional"
+KFMIN=5.115.0
+QTMIN=5.15.12
+inherit ecm gear.kde.org
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://ghostwriter.kde.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/hunspell:=
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwebchannel-${QTMIN}:5
+ >=dev-qt/qtwebengine-${QTMIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+BDEPEND="
+ >=dev-qt/linguist-tools-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+DOCS=( CHANGELOG.md README.md )