summaryrefslogtreecommitdiff
path: root/app-editors/ghostwriter/ghostwriter-23.08.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-12 18:15:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-12 18:15:25 +0100
commit36c436b12f9ef2523e5fd963381b78d2dc5cc53d (patch)
treef275068802d3c71dcdd97439f906e36237263361 /app-editors/ghostwriter/ghostwriter-23.08.2.ebuild
parent3a0e100e02e1c6c2818268f57eae51095cee35af (diff)
gentoo auto-resync : 12:10:2023 - 18:15:24
Diffstat (limited to 'app-editors/ghostwriter/ghostwriter-23.08.2.ebuild')
-rw-r--r--app-editors/ghostwriter/ghostwriter-23.08.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/ghostwriter-23.08.2.ebuild b/app-editors/ghostwriter/ghostwriter-23.08.2.ebuild
new file mode 100644
index 000000000000..3562615eaaf0
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-23.08.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="office"
+ECM_HANDBOOK="optional"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://ghostwriter.kde.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/hunspell:=
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwebchannel-${QTMIN}:5
+ >=dev-qt/qtwebengine-${QTMIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+BDEPEND="
+ >=dev-qt/linguist-tools-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+DOCS=( CHANGELOG.md README.md )