summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
commit9a1d1c6b10a4640cea10e7040ed173cf593f4cab (patch)
tree10b7aaa9608311a4b8a7561c6a8da3003ebb061d /app-editors/gedit-plugins
parentdefbebad0d311b0ce0694b17989a9f26cf000250 (diff)
gentoo auto-resync : 23:01:2023 - 06:54:34
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-44.1.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 7f5a01d75662..6259c8831bb5 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,5 +1,7 @@
DIST gedit-plugins-43.1.tar.xz 913072 BLAKE2B ebfaa6311aac490c75339cf506a58ce60864925ebee8284d72cc4b42634696511d7060eca1b8988d574e1b17dc0e0d32cc934da3c29421339044a220ea5e854e SHA512 2aad05ce15e148121b8e0dcf59546061e448aac09f42c28cee7dfc0b3c16965716059cf147c6391f1c439ac04241e94384bf6ff8dfaa40303dfe80d8de1e2fbc
DIST gedit-plugins-44.0.tar.xz 913176 BLAKE2B 325b70566ba32d6f10edf1681df6d31bf10329389331c9ef4a89671da1b538ff4faebd07c224d5309a113fbb28d40b777fc34c27b8ab1c894abdfeeb2d3683b6 SHA512 878fb3df8ab4e9a338b25da7a8c89c8d8c2dadb78095d2c620448423a2c506e7ab4ac27e823452f0c624ecab97766cc35385271d5889f58a5963b0e343bd63ae
+DIST gedit-plugins-44.1.tar.xz 913228 BLAKE2B a153b82da23f7838da9fa24b28687eae2fd0e4381693515f45e665fc6d9bc2715b37fa6bdac7a8a6ebd947ba0a3a70e5c12708bb14a053c9ad0384549e8ef4f6 SHA512 d5d767210b362747e4ba51b61b4d1c58bf5b37aa5f942cb9654f71c534d8bce2594ebc9004bed686627403fe1c3a6af84a45f4ce72af1f27fa7b644d11cdc9e2
EBUILD gedit-plugins-43.1.ebuild 2587 BLAKE2B 153f1b9fadf48552f0eae523e62b438c5473d81c0b061d94a8817dcb2e4dfdb66f041851e46b42ea34e79875dab5389fb2e4c628d9a883547d261a3c2fc0e524 SHA512 330aba95e9039b2b6f126e39b1e497255079c685dcb9e14f39c5a685b734623054eaa3de49ee5ac25b20c1ed3fa050656ee0a5155d00f98cf5bda3a734daddfb
EBUILD gedit-plugins-44.0.ebuild 2589 BLAKE2B 664cd7f73785128594b7d346d8bce178aad0bceb1fe03fc1093fe621a354862a568b0c85e98c2c21337959ac2e7306e10b21e41f9d6f764e93f8751750092ccd SHA512 9c4b4aee5b01ed15b4356423c741632c05a3b871351e8a29fc0f437e8a6fbdab7eeaa4c873391e6eede91e3860234bd21c87f878083dd5495d36f4e4ecb6ee01
+EBUILD gedit-plugins-44.1.ebuild 2589 BLAKE2B 664cd7f73785128594b7d346d8bce178aad0bceb1fe03fc1093fe621a354862a568b0c85e98c2c21337959ac2e7306e10b21e41f9d6f764e93f8751750092ccd SHA512 9c4b4aee5b01ed15b4356423c741632c05a3b871351e8a29fc0f437e8a6fbdab7eeaa4c873391e6eede91e3860234bd21c87f878083dd5495d36f4e4ecb6ee01
MISC metadata.xml 596 BLAKE2B cf545e591c160fc584c5c2b1e3f5fa6a47922a958f981daa5c85f3f6c8f7eaed2a520d6265241998dfe211098f70c75a0fdfff033e55e892e5775b678ea9ef5b SHA512 0a3b9e748bc2d22ea16a694f8ebd6196d05e6652f552523bfe6fa60f1c69ab50110692cda7a59239c8f6946c06d3139a4225f1744e0dd40ccbdef3e8b396f692
diff --git a/app-editors/gedit-plugins/gedit-plugins-44.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-44.1.ebuild
new file mode 100644
index 000000000000..96f086de69f3
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-44.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ThirdPartyPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-44.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ -Dplugin_drawspaces=true
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}