summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-editors/gedit-plugins
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.30.1.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 49ae4da8bba8..17da3d269675 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-3.28.1.tar.xz 1350468 BLAKE2B 4fd50ad7358581f5e27f0c3a7e127d4e2c0e7189c039daee1d8d7ddf7062846e1aebb634b3edd998c9a7c11840c71f56fe4eeca78ea2e91ae18db814e4fd79e5 SHA512 6258c627cd3fa2948375c30e87061375c0d09ce2c70301c2d10a403e6075d1df09e928a2d95b72f6d7950a31a720af645fff2f7f59a281d2999948beb56c1dc9
+DIST gedit-plugins-3.30.1.tar.xz 1354644 BLAKE2B ee42fb2fe47c9219442e0bbdaf21a14a834b8bc38558713ccf0ad384814812fd71f4d318624b4d2c149b26d304203a2b954ef49c3299877f4d067ae181bfe1d5 SHA512 0e777779288b51015d7ab539bf896a00d5226560f2cc2211daf777da87824eed858255318c421524933a540135e4bfdcc294ba7ed89f680a35aa48f7279cbc94
EBUILD gedit-plugins-3.28.1.ebuild 2291 BLAKE2B 760bdfb31112d8fa8c620022cdaa5d879fb5ee9ec64fade4c5cf91a85d2b22caff4aaa2a86e0cd612bae6de049ce8b0b2de5c4c4b0b3fe6a6a2229e4f2df5951 SHA512 2cb1b9213a8d00ddd96ada96dae546f48856daec2b6811494b9addec47bc5f9279d494da32872f81eb9d68268ebead14c6f175155e7a93da82a81863a1ddbd53
+EBUILD gedit-plugins-3.30.1.ebuild 2345 BLAKE2B a510912fc6a7c3b03ea568a33611081341565fea303e08b69afe3724bbe454dc0dd047843b0e247c1a86a16f1b34ff78ef947e8796dd82bdcf4c92173be44514 SHA512 8fe30e05058fcce8536dadf96a2d0011f8a0e88870f6f6372a4a1e95dedb2d7f91b95c003cdfe28c960d90d049314f04d1dc3a7c9e4f197405be977af3acef79
MISC metadata.xml 542 BLAKE2B 1336fdd161ef76bb2e1445dd074aed82e04be00c9c47885eb5005122c850193dd2bec1aed69dd1da74527c8ee82d7c75d57b73d020cc692e41f6762ba43d8f08 SHA512 1eba6ba724a313d8dd04e838c448cb8de2f3411b891daaacdea615f0d8187d3bbe1f650c9b2ab5457d519ed98dee600d8830e7eea848c872ccb9c52ba58f231a
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.30.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.30.1.ebuild
new file mode 100644
index 000000000000..ee5dd1d5d9d2
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.30.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit eutils gnome2 multilib python-single-r1 vala
+
+DESCRIPTION="Official plugins for gedit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE_plugins="charmap git terminal vala"
+IUSE="+python ${IUSE_plugins}"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=app-editors/gedit-3.16
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-1.7.0[gtk]
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-3.21.3:3.0
+ python? (
+ ${PYTHON_DEPS}
+ >=app-editors/gedit-3.16[introspection,python,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-3.14:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6 )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+ vala? ( $(vala_depend) )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.2
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_enable vala)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # FIXME: crazy !!!
+ if use python; then
+ find "${ED}"/usr/share/gedit -name "*.py*" -delete || die
+ find "${ED}"/usr/share/gedit -type d -empty -delete || die
+ fi
+
+ # FIXME: upstream made this automagic...
+ clean_plugin charmap
+ clean_plugin git
+ clean_plugin terminal
+}
+
+clean_plugin() {
+ if use !${1} ; then
+ rm -rf "${ED}"/usr/share/gedit/plugins/${1}*
+ rm -rf "${ED}"/usr/$(get_libdir)/gedit/plugins/${1}*
+ fi
+}