summaryrefslogtreecommitdiff
path: root/app-editors/emact/emact-2.58.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /app-editors/emact/emact-2.58.0.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'app-editors/emact/emact-2.58.0.ebuild')
-rw-r--r--app-editors/emact/emact-2.58.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-editors/emact/emact-2.58.0.ebuild b/app-editors/emact/emact-2.58.0.ebuild
new file mode 100644
index 000000000000..8d8b17864ccd
--- /dev/null
+++ b/app-editors/emact/emact-2.58.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
+HOMEPAGE="http://www.eligis.com/emacs/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses:0=
+ X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with X x)
+}
+
+src_install() {
+ emake INSTALL="${ED%/}"/usr install
+ #dodoc README
+}