summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-29.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /app-editors/emacs/emacs-29.0.9999.ebuild
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'app-editors/emacs/emacs-29.0.9999.ebuild')
-rw-r--r--app-editors/emacs/emacs-29.0.9999.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-editors/emacs/emacs-29.0.9999.ebuild b/app-editors/emacs/emacs-29.0.9999.ebuild
index c88004a9780d..c016b6f1546a 100644
--- a/app-editors/emacs/emacs-29.0.9999.ebuild
+++ b/app-editors/emacs/emacs-29.0.9999.ebuild
@@ -101,7 +101,10 @@ RDEPEND="app-emacs/emacs-common[games?,gui(-)?]
gmp? ( dev-libs/gmp:0= )
gpm? ( sys-libs/gpm )
!inotify? ( gfile? ( >=dev-libs/glib-2.28.6 ) )
- jit? ( sys-devel/gcc:=[jit(-)] )
+ jit? (
+ sys-devel/gcc:=[jit(-)]
+ sys-libs/zlib
+ )
json? ( dev-libs/jansson:= )
kerberos? ( virtual/krb5 )
lcms? ( media-libs/lcms:2 )
@@ -222,6 +225,14 @@ src_configure() {
# Athena (Lucid), or no toolkit. They are enabled (in order of
# preference) with the "gtk", "motif", "Xaw3d", and "athena" flags.
+ if use jit; then
+ use zlib || ewarn \
+ "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
+ myconf+=" --with-zlib"
+ else
+ myconf+=" $(use_with zlib)"
+ fi
+
if ! use gui; then
einfo "Configuring to build without window system support"
myconf+=" --without-x --without-pgtk --without-ns"
@@ -353,7 +364,6 @@ src_configure() {
$(use_with systemd libsystemd) \
$(use_with threads) \
$(use_with wide-int) \
- $(use_with zlib) \
${myconf}
}