summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-28.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-editors/emacs/emacs-28.0.9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-editors/emacs/emacs-28.0.9999.ebuild')
-rw-r--r--app-editors/emacs/emacs-28.0.9999.ebuild29
1 files changed, 21 insertions, 8 deletions
diff --git a/app-editors/emacs/emacs-28.0.9999.ebuild b/app-editors/emacs/emacs-28.0.9999.ebuild
index fbe5d94d188c..8137dcdd89b8 100644
--- a/app-editors/emacs/emacs-28.0.9999.ebuild
+++ b/app-editors/emacs/emacs-28.0.9999.ebuild
@@ -11,23 +11,35 @@ if [[ ${PV##*.} = 9999 ]]; then
EGIT_BRANCH="master"
EGIT_CHECKOUT_DIR="${WORKDIR}/emacs"
S="${EGIT_CHECKOUT_DIR}"
+ SLOT="${PV%%.*}-vcs"
else
- SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz
- mirror://gnu-alpha/emacs/pretest/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# FULL_VERSION keeps the full version number, which is needed in
# order to determine some path information correctly for copy/move
# operations later on
FULL_VERSION="${PV%%_*}"
+ SRC_URI="mirror://gnu/emacs/${P}.tar.xz"
S="${WORKDIR}/emacs-${FULL_VERSION}"
- [[ ${FULL_VERSION} != ${PV} ]] && S="${WORKDIR}/emacs"
+ # PV can be in any of the following formats:
+ # 27.1 released version (slot 27)
+ # 27.1_rc1 upstream release candidate (27)
+ # 27.0.9999 live ebuild (slot 27-vcs)
+ # 27.0.90 upstream prerelease snapshot (27-vcs)
+ # 27.0.50_pre20191223 snapshot by Gentoo developer (27-vcs)
+ if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+ S="${WORKDIR}/emacs"
+ elif [[ ${PV//[0-9]} != "." ]]; then
+ SRC_URI="mirror://gnu-alpha/emacs/pretest/${PN}-${PV/_/-}.tar.xz"
+ fi
+ SLOT="${PV%%.*}"
+ [[ ${PV} == *.*.* ]] && SLOT+="-vcs"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
fi
DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
-SLOT="28-vcs"
IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
REQUIRED_USE="?? ( aqua X )"
RESTRICT="test"
@@ -368,9 +380,10 @@ src_install() {
/usr/bin/emacs through the Emacs eselect module, which also
redirects man and info pages. Therefore, several Emacs versions can
be installed at the same time. \"man emacs.eselect\" for details.
- \\n\\nIf you upgrade from Emacs version 24.2 or earlier, then it is
- strongly recommended that you use app-admin/emacs-updater to rebuild
- all byte-compiled elisp files of the installed Emacs packages."
+ \\n\\nIf you upgrade from a previous major version of Emacs, then
+ it is strongly recommended that you use app-admin/emacs-updater
+ to rebuild all byte-compiled elisp files of the installed Emacs
+ packages."
use X && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
Installing media-fonts/font-adobe-{75,100}dpi on the X server's
machine would satisfy basic Emacs requirements under X11.