summaryrefslogtreecommitdiff
path: root/app-editors/e3/e3-2.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-editors/e3/e3-2.8.2.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-editors/e3/e3-2.8.2.ebuild')
-rw-r--r--app-editors/e3/e3-2.8.2.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-editors/e3/e3-2.8.2.ebuild b/app-editors/e3/e3-2.8.2.ebuild
index 4d675fa1428c..41f1d83154db 100644
--- a/app-editors/e3/e3-2.8.2.ebuild
+++ b/app-editors/e3/e3-2.8.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
MY_P="${PN}-$(ver_rs 2 '')"
DESCRIPTION="Very tiny editor in ASM with emacs, pico, wordstar, and vi keybindings"
HOMEPAGE="https://sites.google.com/site/e3editor/"
@@ -16,14 +18,10 @@ RESTRICT="strip"
BDEPEND=">=dev-lang/nasm-2.09.04"
S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- sed -i 's/-D$(EXMODE)//' Makefile || die
- eapply_user
-}
+PATCHES=("${FILESDIR}"/${P}-makefile.patch)
src_compile() {
- emake -- $(usex amd64 64 32)
+ emake -- $(usex amd64 64 32) LD="$(tc-getLD)"
}
src_install() {