summaryrefslogtreecommitdiff
path: root/app-editors/cooledit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-editors/cooledit/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-editors/cooledit/files')
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch11
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-copy.patch20
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-gcc4.patch10
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch34
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-interix.patch31
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-interix5.patch13
6 files changed, 119 insertions, 0 deletions
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch b/app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch
new file mode 100644
index 000000000000..4cd6331fcd49
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch
@@ -0,0 +1,11 @@
+diff -ur cooledit-3.17.17.orig/widget/Makefile.am cooledit-3.17.17/widget/Makefile.am
+--- cooledit-3.17.17.orig/widget/Makefile.am 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/widget/Makefile.am 2008-12-07 14:47:18.000000000 +0200
+@@ -20,6 +20,7 @@
+ look-cool.c look-gtk.c look-next.c
+
+ libCw_la_LDFLAGS = -version-info 1:0:0
++libCw_la_LIBADD = @X_LIBS@ -lX11 @X_EXTRA_LIBS@ @LIBINTL@
+
+ DEFS = @X_CFLAGS@ -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/share/cooledit\" @DEFS@
+
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-copy.patch b/app-editors/cooledit/files/cooledit-3.17.17-copy.patch
new file mode 100644
index 000000000000..862b4ec8374c
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-copy.patch
@@ -0,0 +1,20 @@
+diff -crB cooledit-3.17.17/widget/editcmd.c cooledit-new/widget/editcmd.c
+*** cooledit-3.17.17/widget/editcmd.c 2005-04-04 16:47:45.000000000 -0400
+--- cooledit-new/widget/editcmd.c 2009-04-25 21:56:14.000000000 -0400
+***************
+*** 214,220 ****
+ if (file < 0 && (flags & O_CREAT)) /* must it be created ? */
+ return creat ((char *) pathname, mode);
+ close (file);
+! return open ((char *) pathname, flags);
+ }
+
+ /* "Oleg Yu. Repin" <repin@ssd.sscc.ru> added backup filenames
+--- 214,220 ----
+ if (file < 0 && (flags & O_CREAT)) /* must it be created ? */
+ return creat ((char *) pathname, mode);
+ close (file);
+! return open ((char *) pathname, flags, mode);
+ }
+
+ /* "Oleg Yu. Repin" <repin@ssd.sscc.ru> added backup filenames
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-gcc4.patch b/app-editors/cooledit/files/cooledit-3.17.17-gcc4.patch
new file mode 100644
index 000000000000..9ce026146f6a
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-gcc4.patch
@@ -0,0 +1,10 @@
+--- cooledit-3.17.17/widget/coollocal.h.agriffis 2005-04-04 16:47:45.000000000 -0400
++++ cooledit-3.17.17/widget/coollocal.h 2006-03-12 15:38:40.000000000 -0500
+@@ -49,7 +49,6 @@
+ int eh_picture (struct cool_widget *w, XEvent * xevent, CEvent * cwevent);
+ void drawstring_xy (Window win, int x, int y, const char *text);
+ void drawstring_xy_hotkey (Window win, int x, int y, const char *text, int hotkey);
+-int run_callbacks (CWidget * w, XEvent * xevent, CEvent * cwevent);
+ void process_external_focus (Window win, int type);
+ void focus_window (Window win);
+ void link_scrollbar_to_textbox (CWidget * w, CWidget * textbox, XEvent * xevent, CEvent * cwevent, int whichscrbutton);
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch b/app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch
new file mode 100644
index 000000000000..322c36fde936
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch
@@ -0,0 +1,34 @@
+diff -ur cooledit-3.17.17.orig/editor/postscript.c cooledit-3.17.17/editor/postscript.c
+--- cooledit-3.17.17.orig/editor/postscript.c 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/editor/postscript.c 2008-12-07 14:55:25.000000000 +0200
+@@ -1,5 +1,7 @@
+ #include <config.h>
++#include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #ifdef HAVE_SYS_STAT_H
+ #include <sys/stat.h>
+ #endif
+diff -ur cooledit-3.17.17.orig/widget/aafont.c cooledit-3.17.17/widget/aafont.c
+--- cooledit-3.17.17.orig/widget/aafont.c 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/widget/aafont.c 2008-12-07 14:54:23.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include "aafont.h"
+diff -ur cooledit-3.17.17.orig/widget/mad.c cooledit-3.17.17/widget/mad.c
+--- cooledit-3.17.17.orig/widget/mad.c 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/widget/mad.c 2008-12-07 14:54:30.000000000 +0200
+@@ -22,6 +22,8 @@
+ /* Generation MAD. It is based on the debauch package. */
+ /********************************************************************/
+
++#include <stdlib.h>
++#include <string.h>
+ #include "mad.h"
+
+ #undef malloc
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-interix.patch b/app-editors/cooledit/files/cooledit-3.17.17-interix.patch
new file mode 100644
index 000000000000..f6599ae8557c
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-interix.patch
@@ -0,0 +1,31 @@
+diff -ru -x '*.Po' -x '*.Plo' cooledit-3.17.17.orig/editor/_coolpython.c cooledit-3.17.17/editor/_coolpython.c
+--- cooledit-3.17.17.orig/editor/_coolpython.c 2008-04-03 10:59:33 +0200
++++ cooledit-3.17.17/editor/_coolpython.c 2008-04-03 11:02:45 +0200
+@@ -1,4 +1,15 @@
+
++// on interix, need this before config.h to avoid clashes
++// with wchar.h, which cooledit believes is not there, and therefore
++// defines mbstate_t. Python.h includes it, and thus wchar.h messes up.
++#ifdef __cplusplus
++extern "C" {
++#endif
++#include "Python.h"
++#ifdef __cplusplus
++}
++#endif
++
+ #include <config.h>
+
+ #ifdef HAVE_PYTHON
+diff -ru -x '*.Po' -x '*.Plo' cooledit-3.17.17.orig/rxvt/_rxvtlib.h cooledit-3.17.17/rxvt/_rxvtlib.h
+--- cooledit-3.17.17.orig/rxvt/_rxvtlib.h 2008-04-03 11:10:02 +0200
++++ cooledit-3.17.17/rxvt/_rxvtlib.h 2008-04-03 09:00:13 +0200
+@@ -170,7 +170,7 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <net/if.h>
+-#if !defined(__NetBSD__) && !defined(__OpenBSD__)
++#if !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__INTERIX)
+ #include <net/if_arp.h>
+ #endif
+ #include "X11/keysymdef.h"
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-interix5.patch b/app-editors/cooledit/files/cooledit-3.17.17-interix5.patch
new file mode 100644
index 000000000000..46048c334c98
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-interix5.patch
@@ -0,0 +1,13 @@
+diff -ru -x '*.Po' -x '*.Plo' cooledit-3.17.17.orig/rxvt/_rxvtlib.h cooledit-3.17.17/rxvt/_rxvtlib.h
+--- cooledit-3.17.17.orig/rxvt/_rxvtlib.h 2008-04-17 12:09:05 +0200
++++ cooledit-3.17.17/rxvt/_rxvtlib.h 2008-04-17 12:09:31 +0200
+@@ -169,7 +169,9 @@
+ #endif
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
++#ifndef __INTERIX
+ #include <net/if.h>
++#endif
+ #if !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__INTERIX)
+ #include <net/if_arp.h>
+ #endif