summaryrefslogtreecommitdiff
path: root/app-doc/zeal/zeal-0.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /app-doc/zeal/zeal-0.6.1.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'app-doc/zeal/zeal-0.6.1.ebuild')
-rw-r--r--app-doc/zeal/zeal-0.6.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-doc/zeal/zeal-0.6.1.ebuild b/app-doc/zeal/zeal-0.6.1.ebuild
new file mode 100644
index 000000000000..19114642c849
--- /dev/null
+++ b/app-doc/zeal/zeal-0.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Offline documentation browser inspired by Dash"
+HOMEPAGE="https://zealdocs.org/"
+SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="vanilla"
+
+DEPEND="
+ app-arch/libarchive
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/extra-cmake-modules:5
+ >=x11-libs/xcb-util-keysyms-0.3.9
+"
+
+RDEPEND="
+ ${DEPEND}
+ x11-themes/hicolor-icon-theme
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
+ if ! use vanilla; then
+ eapply "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch"
+ fi
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}