summaryrefslogtreecommitdiff
path: root/app-doc/zeal/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-doc/zeal/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-doc/zeal/files')
-rw-r--r--app-doc/zeal/files/0001-libs-enforce-static-linking-of-internal-libs.patch81
-rw-r--r--app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch21
-rw-r--r--app-doc/zeal/files/zeal-0.6.1_p20200815-fix-sidebar-static-lib.patch25
3 files changed, 25 insertions, 102 deletions
diff --git a/app-doc/zeal/files/0001-libs-enforce-static-linking-of-internal-libs.patch b/app-doc/zeal/files/0001-libs-enforce-static-linking-of-internal-libs.patch
deleted file mode 100644
index 137959b7ca28..000000000000
--- a/app-doc/zeal/files/0001-libs-enforce-static-linking-of-internal-libs.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From b08ff87378dab3e6255864d2749e17b71210e7bd Mon Sep 17 00:00:00 2001
-From: Henning Schild <henning@hennsch.de>
-Date: Sat, 9 Mar 2019 16:35:52 +0100
-Subject: [PATCH] libs: enforce static linking of internal libs
-
-Since the application binary is the only file installed and the libs are
-not used by anyone else, make sure they are always static. Otherwise
-cmake can make them shared and those shared libs will be missing after
-install.
-
-Signed-off-by: Henning Schild <henning@hennsch.de>
----
- src/libs/core/CMakeLists.txt | 2 +-
- src/libs/registry/CMakeLists.txt | 2 +-
- src/libs/ui/CMakeLists.txt | 2 +-
- src/libs/ui/qxtglobalshortcut/CMakeLists.txt | 2 +-
- src/libs/util/CMakeLists.txt | 2 +-
- 5 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/libs/core/CMakeLists.txt b/src/libs/core/CMakeLists.txt
-index cd212bb..3bd7371 100644
---- a/src/libs/core/CMakeLists.txt
-+++ b/src/libs/core/CMakeLists.txt
-@@ -1,4 +1,4 @@
--add_library(Core
-+add_library(Core STATIC
- application.cpp
- applicationsingleton.cpp
- extractor.cpp
-diff --git a/src/libs/registry/CMakeLists.txt b/src/libs/registry/CMakeLists.txt
-index 3372711..977919d 100644
---- a/src/libs/registry/CMakeLists.txt
-+++ b/src/libs/registry/CMakeLists.txt
-@@ -1,4 +1,4 @@
--add_library(Registry
-+add_library(Registry STATIC
- cancellationtoken.h
- docset.cpp
- docsetmetadata.cpp
-diff --git a/src/libs/ui/CMakeLists.txt b/src/libs/ui/CMakeLists.txt
-index 1fe12ef..27a4877 100644
---- a/src/libs/ui/CMakeLists.txt
-+++ b/src/libs/ui/CMakeLists.txt
-@@ -16,7 +16,7 @@ set(Ui_FORMS
- settingsdialog.ui
- )
-
--add_library(Ui
-+add_library(Ui STATIC
- aboutdialog.cpp
- docsetlistitemdelegate.cpp
- docsetsdialog.cpp
-diff --git a/src/libs/ui/qxtglobalshortcut/CMakeLists.txt b/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
-index 8b1b0ef..1776839 100644
---- a/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
-+++ b/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
-@@ -19,7 +19,7 @@ elseif(WIN32)
- )
- endif()
-
--add_library(QxtGlobalShortcut ${QxtGlobalShortcut_SOURCES})
-+add_library(QxtGlobalShortcut STATIC ${QxtGlobalShortcut_SOURCES})
-
- find_package(Qt5Gui REQUIRED)
- target_link_libraries(QxtGlobalShortcut Qt5::Gui)
-diff --git a/src/libs/util/CMakeLists.txt b/src/libs/util/CMakeLists.txt
-index d4ab871..ad0e9ec 100644
---- a/src/libs/util/CMakeLists.txt
-+++ b/src/libs/util/CMakeLists.txt
-@@ -1,7 +1,7 @@
- # Nothing to moc here, so avoid empty build units.
- set(CMAKE_AUTOMOC OFF)
-
--add_library(Util
-+add_library(Util STATIC
- plist.cpp
- sqlitedatabase.cpp
- version.cpp
---
-2.19.2
-
diff --git a/app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch b/app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch
deleted file mode 100644
index 45459b8c3678..000000000000
--- a/app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 064aaa05d6a3ba4ba3cf648199a3109aba2f41fe Mon Sep 17 00:00:00 2001
-From: Dmitry Atamanov <data-man@users.noreply.github.com>
-Date: Sun, 26 Apr 2020 02:26:53 +0500
-Subject: [PATCH] fix(ui): fix compilation error with Qt 5.15 (#1218)
-
----
- src/libs/ui/searchitemdelegate.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/libs/ui/searchitemdelegate.cpp b/src/libs/ui/searchitemdelegate.cpp
-index 464e4859..4a9c473b 100644
---- a/src/libs/ui/searchitemdelegate.cpp
-+++ b/src/libs/ui/searchitemdelegate.cpp
-@@ -27,6 +27,7 @@
- #include <QFontMetrics>
- #include <QHelpEvent>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QToolTip>
-
- using namespace Zeal::WidgetUi;
diff --git a/app-doc/zeal/files/zeal-0.6.1_p20200815-fix-sidebar-static-lib.patch b/app-doc/zeal/files/zeal-0.6.1_p20200815-fix-sidebar-static-lib.patch
new file mode 100644
index 000000000000..0a5a8f69be2d
--- /dev/null
+++ b/app-doc/zeal/files/zeal-0.6.1_p20200815-fix-sidebar-static-lib.patch
@@ -0,0 +1,25 @@
+From b48ee895ce7fc1db1dce20dac5115ec4c60f75fa Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 18 Aug 2020 15:03:59 +0200
+Subject: [PATCH] sidebar: Add missing STATIC keyword (similar to #1085)
+
+Fixes unresolved soname dependency after install.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/libs/sidebar/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libs/sidebar/CMakeLists.txt b/src/libs/sidebar/CMakeLists.txt
+index 4332b8f..dc6be0e 100644
+--- a/src/libs/sidebar/CMakeLists.txt
++++ b/src/libs/sidebar/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-add_library(Sidebar
++add_library(Sidebar STATIC
+ container.cpp
+ proxyview.cpp
+ view.cpp
+--
+2.28.0
+