summaryrefslogtreecommitdiff
path: root/app-doc/xmltoman/xmltoman-0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-doc/xmltoman/xmltoman-0.4-r2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-doc/xmltoman/xmltoman-0.4-r2.ebuild')
-rw-r--r--app-doc/xmltoman/xmltoman-0.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-doc/xmltoman/xmltoman-0.4-r2.ebuild b/app-doc/xmltoman/xmltoman-0.4-r2.ebuild
new file mode 100644
index 000000000000..efb9811d3457
--- /dev/null
+++ b/app-doc/xmltoman/xmltoman-0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple scripts for converting xml to groff or html"
+HOMEPAGE="https://sourceforge.net/projects/xmltoman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ # 'make install' requires GNU install, upstream is dead and carrying
+ # a patch is more space than redoing it here
+ dobin xmltoman xmlmantohtml
+
+ insinto /usr/share/xmltoman
+ doins xmltoman.{css,dtd,xsl}
+
+ dodoc README
+ doman xmltoman.1 xmlmantohtml.1
+}