summaryrefslogtreecommitdiff
path: root/app-doc/tldp-howto/tldp-howto-20120707.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/tldp-howto/tldp-howto-20120707.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/tldp-howto/tldp-howto-20120707.ebuild')
-rw-r--r--app-doc/tldp-howto/tldp-howto-20120707.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-doc/tldp-howto/tldp-howto-20120707.ebuild b/app-doc/tldp-howto/tldp-howto-20120707.ebuild
new file mode 100644
index 000000000000..b2f67e831063
--- /dev/null
+++ b/app-doc/tldp-howto/tldp-howto-20120707.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="The Linux Documentation Project HOWTOs"
+HOMEPAGE="http://www.tldp.org"
+
+MY_SRC="http://www.ibiblio.org/pub/Linux/docs/HOWTO"
+SRC_URI="
+ html? ( ${MY_SRC}/other-formats/html/Linux-html-HOWTOs-${PV}.tar.bz2 )
+ htmlsingle? ( ${MY_SRC}/other-formats/html_single/Linux-html-single-HOWTOs-${PV}.tar.bz2 )
+ pdf? ( ${MY_SRC}/other-formats/pdf/Linux-pdf-HOWTOs-${PV}.tar.bz2 )
+ text? ( ${MY_SRC}/Linux-HOWTOs-${PV}.tar.bz2 )"
+
+LICENSE="FDL-1.2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="+html htmlsingle pdf text"
+REQUIRED_USE="|| ( html htmlsingle pdf text )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cd "${S}"
+ if use html; then
+ unpack Linux-html-HOWTOs-${PV}.tar.bz2
+ # for some reason this bundles the pdfs - older versions didn't
+ [[ -d ${S}/HOWTO/pdf ]] && rm -r "${S}"/HOWTO/pdf
+ # stray bin file, doubt anyone will ever need it
+ rm -f "${S}"/HOWTO/RedHat-CD-HOWTO/rhcd-scripts/rvc
+ mv "${S}"/HOWTO "${S}"/html
+ fi
+ if use htmlsingle; then
+ mkdir "${S}"/htmlsingle || die
+ pushd "${S}"/htmlsingle > /dev/null
+ unpack Linux-html-single-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+ if use pdf; then
+ mkdir "${S}"/pdf || die
+ pushd "${S}"/pdf > /dev/null
+ unpack Linux-pdf-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+ if use text; then
+ mkdir "${S}"/text || die
+ pushd "${S}"/text > /dev/null
+ unpack Linux-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}"/*
+}