summaryrefslogtreecommitdiff
path: root/app-doc/python-docs/python-docs-3.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-10 12:32:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-10 12:32:09 +0100
commitbcb1bf8297438e33e98fec6991ba68dec0f4dd7c (patch)
tree641656fce8ff13ec9fae86d68bd03073d9afc4a0 /app-doc/python-docs/python-docs-3.12.3.ebuild
parentfb0d4b003026d01b3d52956c7a0069b9363efff8 (diff)
gentoo auto-resync : 10:04:2024 - 12:32:09
Diffstat (limited to 'app-doc/python-docs/python-docs-3.12.3.ebuild')
-rw-r--r--app-doc/python-docs/python-docs-3.12.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-doc/python-docs/python-docs-3.12.3.ebuild b/app-doc/python-docs/python-docs-3.12.3.ebuild
new file mode 100644
index 000000000000..8483ad559ab4
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.12.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}