summaryrefslogtreecommitdiff
path: root/app-doc/python-docs/python-docs-3.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
commit909e6f36d5376b253aba44edc8f2af1a5acd0c11 (patch)
tree048569e21e5eb27492bcd1fa73bbc1cc462b3ce5 /app-doc/python-docs/python-docs-3.12.1.ebuild
parentac778f2cf394586c43beb5d753a19ff3f6063556 (diff)
gentoo auto-resync : 08:12:2023 - 11:11:23
Diffstat (limited to 'app-doc/python-docs/python-docs-3.12.1.ebuild')
-rw-r--r--app-doc/python-docs/python-docs-3.12.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-doc/python-docs/python-docs-3.12.1.ebuild b/app-doc/python-docs/python-docs-3.12.1.ebuild
new file mode 100644
index 000000000000..2ab918028481
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.12.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}