summaryrefslogtreecommitdiff
path: root/app-doc/python-docs/python-docs-3.10.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-24 21:52:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-24 21:52:33 +0100
commit27ddeb821d437a2d848d9fa85a30f88f48fb52a6 (patch)
treeff7929a09cd2ebf0d87cf6970bfa9168dc4bcb07 /app-doc/python-docs/python-docs-3.10.13.ebuild
parentc7a2fa9581ac6df998adac5277043bb8014861fb (diff)
gentoo auto-resync : 24:08:2023 - 21:52:33
Diffstat (limited to 'app-doc/python-docs/python-docs-3.10.13.ebuild')
-rw-r--r--app-doc/python-docs/python-docs-3.10.13.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-doc/python-docs/python-docs-3.10.13.ebuild b/app-doc/python-docs/python-docs-3.10.13.ebuild
new file mode 100644
index 000000000000..2ab918028481
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.13.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}