summaryrefslogtreecommitdiff
path: root/app-doc/python-docs/python-docs-2.7.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-06 17:34:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-06 17:34:33 +0100
commitfb6a7e84128cd7df87023d4e7d224de83057f748 (patch)
tree6ace847db7319686f5aeb137202fa1d273c75491 /app-doc/python-docs/python-docs-2.7.18.ebuild
parent0e52cbae2c719c3ef794ebeb0f4374fb96efcff3 (diff)
gentoo auto-resync : 06:05:2023 - 17:34:33
Diffstat (limited to 'app-doc/python-docs/python-docs-2.7.18.ebuild')
-rw-r--r--app-doc/python-docs/python-docs-2.7.18.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-doc/python-docs/python-docs-2.7.18.ebuild b/app-doc/python-docs/python-docs-2.7.18.ebuild
new file mode 100644
index 000000000000..e0ae576a6a47
--- /dev/null
+++ b/app-doc/python-docs/python-docs-2.7.18.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}