summaryrefslogtreecommitdiff
path: root/app-doc/halibut
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /app-doc/halibut
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'app-doc/halibut')
-rw-r--r--app-doc/halibut/Manifest3
-rw-r--r--app-doc/halibut/files/halibut-1.2-fno-common.patch22
-rw-r--r--app-doc/halibut/halibut-1.2.ebuild5
3 files changed, 27 insertions, 3 deletions
diff --git a/app-doc/halibut/Manifest b/app-doc/halibut/Manifest
index 0aaf11f90040..c85a8e5f6560 100644
--- a/app-doc/halibut/Manifest
+++ b/app-doc/halibut/Manifest
@@ -1,3 +1,4 @@
+AUX halibut-1.2-fno-common.patch 408 BLAKE2B b976e2385b0e2feacddb50bc63094d419cc11d4c840ccc948049b76df8425e64dc0589190d62ede4e510f4fab25d7c9db3d860372889f04b141c7cf48b081e8e SHA512 e1559fe7288c735c6cc29eb86d615d4d9e593c360226cef916e105bef3498d5ba269dab897d1be37702b8642ff8d40f9f9128f20d42d1b41c57bd10d47d7242e
DIST halibut-1.2.tar.gz 991975 BLAKE2B e5751d2f90968240825e3ddadbc070de856f6a340e832bcf0977fb8d31f7b7c8eefa776f3bba4df58641d22cca7e9ac562eef236069e1d9a8e9cdb41324a7376 SHA512 b04cc5c52f2d7cd2bb9a36a1aa896c6a4fd11bcfc5fad3d9c74576bf2576ce237cd7ac3ceeff3bd10dfd5a229614d06d23323509d3a83ff74b4a1965e1d726fc
-EBUILD halibut-1.2.ebuild 850 BLAKE2B 7b224fda43aef3ced94758cc7cb7262925b19d19e109fe51c72f629401bd8aa518f42fe8279f12048fba57197503503898d6cb6dc7d116bf6e5e050d85e63898 SHA512 d1e38ef45fc876a9484b8cc005f77c98a72db671b4c35aebd5392268817e0d7f4f798f321f4a5113273a6763beb262d2fdde4e11739ce05f6d86c2874ee5d4f4
+EBUILD halibut-1.2.ebuild 888 BLAKE2B 7d066763af3d20e3c78ae84aa3ca455d9715c4c61868923e85b8511fde458aac1cb02da5c5cbae57710e1921826b660de78c6b42e7959f50b6f0570f44402eb5 SHA512 1dead2071184ae270f3f0efc44df410dfda6caf53739b10e0493139975c6691d475f3cc4b757f492e7eefc45ec82511ef0531b87d4d3fafaf2273541521e338f
MISC metadata.xml 248 BLAKE2B 098d4976304542e71e494b46eb846b1ddc3f761a0e1eb4477c68fb0270bfd195de3fa8da7de3cf5a86d33442d7f1fc30fded9f56346e784edfbb969387d62eb5 SHA512 5a0cba98b94cc06306b0e352d40ff113de69408752b14e1ba9efdce3f564c9bd11f8f65e89fc24d2e2056056edef5b77ab1ca8aa33e7faad5d0eaef40b895c85
diff --git a/app-doc/halibut/files/halibut-1.2-fno-common.patch b/app-doc/halibut/files/halibut-1.2-fno-common.patch
new file mode 100644
index 000000000000..e547e304d9c3
--- /dev/null
+++ b/app-doc/halibut/files/halibut-1.2-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/bk_paper.c
++++ b/bk_paper.c
+@@ -75,6 +75,8 @@
+ #include "halibut.h"
+ #include "paper.h"
+
++font_info *all_fonts;
++
+ typedef struct paper_conf_Tag paper_conf;
+ typedef struct paper_idx_Tag paper_idx;
+
+--- a/paper.h
++++ b/paper.h
+@@ -78,7 +78,7 @@ struct ligature_Tag {
+ * metrics are read in.
+ */
+
+-font_info *all_fonts;
++extern font_info *all_fonts;
+
+ struct font_info_Tag {
+ font_info *next;
diff --git a/app-doc/halibut/halibut-1.2.ebuild b/app-doc/halibut/halibut-1.2.ebuild
index 13c64206e3f6..933b648f2be5 100644
--- a/app-doc/halibut/halibut-1.2.ebuild
+++ b/app-doc/halibut/halibut-1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -12,7 +12,8 @@ SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_compile() {
tc-export CC