summaryrefslogtreecommitdiff
path: root/app-doc/gnu-c-intro-ref
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-22 02:55:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-22 02:55:39 +0100
commit470949042cc90856adb62f2671e04e3165fc8063 (patch)
treee577a02af2278fdc686930a13421f68abe332fd6 /app-doc/gnu-c-intro-ref
parenteb509e1a15f595f667e8d177ddb73311084af6c0 (diff)
gentoo auto-resync : 22:05:2023 - 02:55:39
Diffstat (limited to 'app-doc/gnu-c-intro-ref')
-rw-r--r--app-doc/gnu-c-intro-ref/Manifest4
-rw-r--r--app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20230521.ebuild45
-rw-r--r--app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild45
-rw-r--r--app-doc/gnu-c-intro-ref/metadata.xml11
4 files changed, 105 insertions, 0 deletions
diff --git a/app-doc/gnu-c-intro-ref/Manifest b/app-doc/gnu-c-intro-ref/Manifest
new file mode 100644
index 000000000000..5e801616ab09
--- /dev/null
+++ b/app-doc/gnu-c-intro-ref/Manifest
@@ -0,0 +1,4 @@
+DIST c-intro-and-ref-36a1041cfa542b8c00aa6daad2624797164d87f4.tar.gz 195859 BLAKE2B d2a6b32e1f19c88c947e3a98825cdf6eec8192a6e79b4eb9b47bbb69368e2dcb8bb6a6e77dbf05070b918aead7d60d72dd9afcd719a7c1f8d51793fe2ababaa0 SHA512 bd4bd01a24a941c7272d0e9e88867a1669779e390f50725c883bd18cd578899529d2179c919a0a4db386bcb59d3e485a3487b762ee499ee4585e9c579b802787
+EBUILD gnu-c-intro-ref-0_pre20230521.ebuild 929 BLAKE2B 55d8574d3f2f94f8c940bbf04ecf5440855ebc66813a2cb964032370369d3b95654746719fb45baaaa547949b4aabef3d6edba1a588079fd31852b40aabf299f SHA512 835c3ed58bc34dbf03d2151af0a07bb9c638fa5eaccf8b294cafd6dd66b7a0682a420b2a001e6f778ded70b8772c7a766058fc39763957474d43a780d8f863e1
+EBUILD gnu-c-intro-ref-9999.ebuild 929 BLAKE2B 55d8574d3f2f94f8c940bbf04ecf5440855ebc66813a2cb964032370369d3b95654746719fb45baaaa547949b4aabef3d6edba1a588079fd31852b40aabf299f SHA512 835c3ed58bc34dbf03d2151af0a07bb9c638fa5eaccf8b294cafd6dd66b7a0682a420b2a001e6f778ded70b8772c7a766058fc39763957474d43a780d8f863e1
+MISC metadata.xml 322 BLAKE2B 441035337e181250ff73319719b7d251902bc20e800364fca9584e950d47d99eb97968df9da749194d91cd90b1db505160f796184d8a331d767a63f51f69b2cc SHA512 4951111aa627d871cbd86d4ac8a6f37986857a88fda66d439a88c20d2fcec6bd1f33489973ce557c7b7ee330a1f2d50275fe4744677c9b2fe145bc66a825e94a
diff --git a/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20230521.ebuild b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20230521.ebuild
new file mode 100644
index 000000000000..206a80678ffc
--- /dev/null
+++ b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-0_pre20230521.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GNU C Language Intro and Reference Manual"
+HOMEPAGE="https://savannah.gnu.org/projects/c-intro-and-ref/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/c-intro-and-ref.git"
+ inherit git-r3
+else
+ MY_COMMIT="36a1041cfa542b8c00aa6daad2624797164d87f4"
+ SRC_URI="https://git.savannah.nongnu.org/cgit/c-intro-and-ref.git/snapshot/c-intro-and-ref-${MY_COMMIT}.tar.gz"
+ S="${WORKDIR}"/c-intro-and-ref-${MY_COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="FDL-1.3+"
+SLOT="0"
+IUSE="pdf"
+
+BDEPEND="
+ sys-apps/texinfo
+ pdf? (
+ app-text/ghostscript-gpl
+ app-text/texlive-core
+ )
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_compile() {
+ emake info html $(usev pdf 'pdf')
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-info install-html $(usev pdf 'install-pdf')
+}
diff --git a/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild
new file mode 100644
index 000000000000..206a80678ffc
--- /dev/null
+++ b/app-doc/gnu-c-intro-ref/gnu-c-intro-ref-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GNU C Language Intro and Reference Manual"
+HOMEPAGE="https://savannah.gnu.org/projects/c-intro-and-ref/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/c-intro-and-ref.git"
+ inherit git-r3
+else
+ MY_COMMIT="36a1041cfa542b8c00aa6daad2624797164d87f4"
+ SRC_URI="https://git.savannah.nongnu.org/cgit/c-intro-and-ref.git/snapshot/c-intro-and-ref-${MY_COMMIT}.tar.gz"
+ S="${WORKDIR}"/c-intro-and-ref-${MY_COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="FDL-1.3+"
+SLOT="0"
+IUSE="pdf"
+
+BDEPEND="
+ sys-apps/texinfo
+ pdf? (
+ app-text/ghostscript-gpl
+ app-text/texlive-core
+ )
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_compile() {
+ emake info html $(usev pdf 'pdf')
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-info install-html $(usev pdf 'install-pdf')
+}
diff --git a/app-doc/gnu-c-intro-ref/metadata.xml b/app-doc/gnu-c-intro-ref/metadata.xml
new file mode 100644
index 000000000000..ba8bf116c4f5
--- /dev/null
+++ b/app-doc/gnu-c-intro-ref/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="savannah">c-intro-and-ref</remote-id>
+ </upstream>
+</pkgmetadata>