summaryrefslogtreecommitdiff
path: root/app-doc/elisp-manual/elisp-manual-25.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/elisp-manual/elisp-manual-25.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-25.3.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-25.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-25.3.ebuild b/app-doc/elisp-manual/elisp-manual-25.3.ebuild
new file mode 100644
index 000000000000..10e056f739c7
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-25.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
+# taken from doc/lispref/ (and some files from doc/emacs/) of emacs-${PV}
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="FDL-1.3+"
+SLOT="25"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+DEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/lispref"
+PATCHES=("${FILESDIR}/${P}-direntry.patch")
+
+src_compile() {
+ makeinfo -I "${WORKDIR}"/emacs elisp.texi || die
+}
+
+src_install() {
+ doinfo elisp${SLOT}.info*
+ dodoc README
+}