summaryrefslogtreecommitdiff
path: root/app-doc/elisp-manual/elisp-manual-25.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-doc/elisp-manual/elisp-manual-25.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-25.3.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-25.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-25.3.ebuild b/app-doc/elisp-manual/elisp-manual-25.3.ebuild
new file mode 100644
index 000000000000..348832c80cfb
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-25.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
+# taken from doc/lispref/ (and some files from doc/emacs/) of emacs-${PV}
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="FDL-1.3+"
+SLOT="25"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+DEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/lispref"
+PATCHES=("${FILESDIR}/${P}-direntry.patch")
+
+src_compile() {
+ makeinfo -I "${WORKDIR}"/emacs elisp.texi || die
+}
+
+src_install() {
+ doinfo elisp${SLOT}.info*
+ dodoc README
+}