summaryrefslogtreecommitdiff
path: root/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild b/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild
new file mode 100644
index 000000000000..57b9eb43552c
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-19.2.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${PN}-${PV/./-}
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
+SRC_URI="ftp://ftp.gnu.org/old-gnu/emacs/${MY_P}.tar.gz
+ https://dev.gentoo.org/~ulm/emacs/${P}-patches.tar.gz"
+
+LICENSE="Texinfo-manual"
+SLOT="19"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # remove pre-made info files
+ rm -f elisp elisp-[0-9]*
+ EPATCH_SUFFIX=patch epatch
+}
+
+src_compile() {
+ ln -s index.unperm index.texi || die
+ makeinfo elisp.texi || die
+}
+
+src_install() {
+ doinfo elisp19.info*
+ dodoc README
+}