summaryrefslogtreecommitdiff
path: root/app-doc/doxygen/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-doc/doxygen/files
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch32
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch24
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch20
3 files changed, 0 insertions, 76 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch
deleted file mode 100644
index cdc630c4d42b..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/addon/doxysearch/CMakeLists.txt b/addon/doxysearch/CMakeLists.txt
-index 33e01c1..165fc3e 100644
---- a/addon/doxysearch/CMakeLists.txt
-+++ b/addon/doxysearch/CMakeLists.txt
-@@ -20,6 +20,7 @@ target_link_libraries(doxyindexer
- ${ZLIB_LIBRARIES}
- ${WIN_EXTRA_LIBS}
- qtools
-+ pthread
- )
-
- add_executable(doxysearch.cgi
-@@ -29,6 +30,7 @@ target_link_libraries(doxysearch.cgi
- ${XAPIAN_LIBRARIES}
- ${ZLIB_LIBRARIES}
- ${WIN_EXTRA_LIBS}
-+ pthread
- )
-
- install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
-diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
-index bf2eda8..8eb2a1c 100644
---- a/addon/doxywizard/CMakeLists.txt
-+++ b/addon/doxywizard/CMakeLists.txt
-@@ -109,6 +109,7 @@ ${doxywizard_RESOURCES_RCC}
- qt_use_modules(doxywizard Core Gui Widgets Xml)
- target_link_libraries(doxywizard
- ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY}
-+pthread
- )
-
- install(TARGETS doxywizard DESTINATION bin)
diff --git a/app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch b/app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch
deleted file mode 100644
index 8d72e8ff6e0d..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 0f02761a158a5e9ddbd5801682482af8986dbc35 Mon Sep 17 00:00:00 2001
-From: albert-github <albert.tests@gmail.com>
-Date: Wed, 4 Jan 2017 12:24:55 +0100
-Subject: [PATCH] Bug 776791 - [1.8.13 Regression] Segfault building the
- breathe docs
-
-Protected against NULL pointer of variable al
----
- src/xmlgen.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/xmlgen.cpp b/src/xmlgen.cpp
-index fe95c7a..70e198a 100644
---- a/src/xmlgen.cpp
-+++ b/src/xmlgen.cpp
-@@ -620,7 +620,7 @@ static void generateXMLForMember(MemberDef *md,FTextStream &ti,FTextStream &t,De
- if (md->isInline()) t << "yes"; else t << "no";
- t << "\"";
-
-- if (al->refQualifier!=RefQualifierNone)
-+ if (al!=0 && al->refQualifier!=RefQualifierNone)
- {
- t << " refqual=\"";
- if (al->refQualifier==RefQualifierLValue) t << "lvalue"; else t << "rvalue";
diff --git a/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch b/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch
deleted file mode 100644
index cfa56174c5eb..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-removeEmptyLines() segfaults on empty string
-
-https://bugs.gentoo.org/show_bug.cgi?id=454348
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676423
-
-Patch written by Thibaut Paumard <paumard@users.sourceforge.net>
---- a/src/htmlgen.cpp
-+++ b/src/htmlgen.cpp
-@@ -1022,6 +1022,11 @@
- static QCString removeEmptyLines(const QCString &s)
- {
- BufStr out(s.length()+1);
-+ if (s.length()==0)
-+ {
-+ out.addChar('\0');
-+ return out.data();
-+ }
- const char *p=s.data();
- if (p)
- {