summaryrefslogtreecommitdiff
path: root/app-doc/doxygen/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /app-doc/doxygen/files
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch32
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch23
2 files changed, 23 insertions, 32 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch
deleted file mode 100644
index cdc630c4d42b..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/addon/doxysearch/CMakeLists.txt b/addon/doxysearch/CMakeLists.txt
-index 33e01c1..165fc3e 100644
---- a/addon/doxysearch/CMakeLists.txt
-+++ b/addon/doxysearch/CMakeLists.txt
-@@ -20,6 +20,7 @@ target_link_libraries(doxyindexer
- ${ZLIB_LIBRARIES}
- ${WIN_EXTRA_LIBS}
- qtools
-+ pthread
- )
-
- add_executable(doxysearch.cgi
-@@ -29,6 +30,7 @@ target_link_libraries(doxysearch.cgi
- ${XAPIAN_LIBRARIES}
- ${ZLIB_LIBRARIES}
- ${WIN_EXTRA_LIBS}
-+ pthread
- )
-
- install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
-diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
-index bf2eda8..8eb2a1c 100644
---- a/addon/doxywizard/CMakeLists.txt
-+++ b/addon/doxywizard/CMakeLists.txt
-@@ -109,6 +109,7 @@ ${doxywizard_RESOURCES_RCC}
- qt_use_modules(doxywizard Core Gui Widgets Xml)
- target_link_libraries(doxywizard
- ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY}
-+pthread
- )
-
- install(TARGETS doxywizard DESTINATION bin)
diff --git a/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch b/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
new file mode 100644
index 000000000000..5dd7578f24ec
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
@@ -0,0 +1,23 @@
+Hack to avoid "UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb0 in position 45: invalid start byte"
+in src/._xmlgen.cpp which is binary. This doesn't seem like it should be present at the time the docs
+are generated, but this is simpler for now.
+--- a/doc/translator.py
++++ b/doc/translator.py
+@@ -1454,10 +1454,13 @@ class TrManager:
+
+ # Read content of the file as one string.
+ assert os.path.isfile(fname)
+- f = xopen(fname)
+- cont = f.read()
+- cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
+- f.close()
++ try:
++ with xopen(fname) as f:
++ cont = f.read()
++ cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
++ except UnicodeDecodeError:
++ print("Skipping {0} because of decoding errors".format(fname))
++ return
+
+ # Remove the items for identifiers that were found in the file.
+ while lst_in: