summaryrefslogtreecommitdiff
path: root/app-doc/doxygen/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-doc/doxygen/files
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch25
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch50
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch39
3 files changed, 89 insertions, 25 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch b/app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch
deleted file mode 100644
index 86e6d7999418..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 5c55efae..1ad32b2e 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -262,7 +262,7 @@ if (use_libclang)
- add_definitions(${LLVM_DEFINITIONS})
- llvm_map_components_to_libnames(llvm_libs support core option)
- target_compile_definitions(doxygen PRIVATE ${LLVM_DEFINITIONS})
-- set(CLANG_LIBS libclang clangTooling ${llvm_libs})
-+ set(CLANG_LIBS libclang clangTooling clangBasic clangLex ${llvm_libs})
- endif()
-
- target_link_libraries(doxygen
-diff --git a/src/clangparser.cpp b/src/clangparser.cpp
-index 77151d6e..2ea15ee2 100644
---- a/src/clangparser.cpp
-+++ b/src/clangparser.cpp
-@@ -4,6 +4,7 @@
-
- #if USE_LIBCLANG
- #include <clang-c/Index.h>
-+#include "clang/Tooling/CompilationDatabase.h"
- #include "clang/Tooling/Tooling.h"
- #include <qfileinfo.h>
- #include <stdlib.h>
diff --git a/app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch b/app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch
new file mode 100644
index 000000000000..cc0704b440f6
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch
@@ -0,0 +1,50 @@
+From 4a72a9b07e805b4ba27560e8e921bcee0002ef4c Mon Sep 17 00:00:00 2001
+From: albert-github <albert.tests@gmail.com>
+Date: Mon, 9 Sep 2019 13:28:28 +0200
+Subject: [PATCH] issue #7248: Including external tag files with TOC produces a
+ broken index.qhp
+
+Ignore automatically generated anchor names when importing a tag file.
+
+Upstream: https://github.com/doxygen/doxygen/pull/7250
+---
+ src/tagreader.cpp | 19 ++++++++++++++++++-
+ 1 file changed, 18 insertions(+), 1 deletion(-)
+
+diff --git a/src/tagreader.cpp b/src/tagreader.cpp
+index 56dbe7df9..d79d9b5c5 100644
+--- a/src/tagreader.cpp
++++ b/src/tagreader.cpp
+@@ -494,6 +494,23 @@ class TagFileParser : public QXmlDefaultHandler
+
+ void endDocAnchor()
+ {
++ // Check whether or not the tag is automatically generate, in that case ignore the tag.
++ switch(m_state)
++ {
++ case InClass:
++ case InFile:
++ case InNamespace:
++ case InGroup:
++ case InPage:
++ case InMember:
++ case InPackage:
++ case InDir:
++ if (QString(m_curString).startsWith("autotoc_md")) return;
++ break;
++ default:
++ warn("Unexpected tag 'docanchor' found");
++ return;
++ }
+ switch(m_state)
+ {
+ case InClass: m_curClass->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
+@@ -504,7 +521,7 @@ class TagFileParser : public QXmlDefaultHandler
+ case InMember: m_curMember->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
+ case InPackage: m_curPackage->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
+ case InDir: m_curDir->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
+- default: warn("Unexpected tag 'docanchor' found"); break;
++ default: warn("Unexpected tag 'docanchor' found"); break; // Not really necessary anymore
+ }
+ }
+
diff --git a/app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch b/app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch
new file mode 100644
index 000000000000..55445fa19dc4
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch
@@ -0,0 +1,39 @@
+From f08e87623368134c6541af12995b811ef9aff069 Mon Sep 17 00:00:00 2001
+From: albert-github <albert.tests@gmail.com>
+Date: Tue, 12 Nov 2019 11:42:22 +0100
+Subject: [PATCH] issue #7290 error: Problem running ghostscript gs -q -g562x56
+ -r384x384x -sDEVICE=ppmraw -sOutputFile=_form0.pnm -dNOPAUSE -dBATCH --
+ _form0.ps. Check your installation!
+
+@maehr had a talk with Robin Watts and Ken Sharp at IRC and there seem to be basically 3 different problems:
+* `-r%dx%d` (the dimension for `r` shouldn't be `-r384x384x`, but `-r384x384`),
+* misuse / unnecessary use of `--` and
+* since 9.50 the command needs more control access (that might be worked around by either whitelisting the file via `--permit-file-read=_form0.eps` (only works from 9.50 and upwards) or generally accepting any file with `-dNOSAFER` (works since quite some time). The second option is considered to be unsafe if we would process any file, but in this case we process self produced / controlled files. I don't know if doxygen has any threat model that it assumes. ).
+
+> Ken Sharp: Yeah the %dx is wrong, as Robin says its sheer luck that works
+the -- isn't needed and is what's causing the first problem
+and file control is the new bugbear
+
+The suggestions have been implemented and test / docs works now with old and new version.
+---
+ src/formula.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/formula.cpp b/src/formula.cpp
+index 534f56ac..3d8e6ce1 100644
+--- a/src/formula.cpp
++++ b/src/formula.cpp
+@@ -193,8 +193,8 @@ void FormulaList::generateBitmaps(const char *path)
+ // used.
+
+ char gsArgs[4096];
+- sprintf(gsArgs,"-q -g%dx%d -r%dx%dx -sDEVICE=ppmraw "
+- "-sOutputFile=%s.pnm -dNOPAUSE -dBATCH -- %s.ps",
++ sprintf(gsArgs,"-q -g%dx%d -r%dx%d -sDEVICE=ppmraw "
++ "-sOutputFile=%s.pnm -dNOPAUSE -dBATCH -dNOSAFER %s.ps",
+ gx,gy,(int)(scaleFactor*72),(int)(scaleFactor*72),
+ formBase.data(),formBase.data()
+ );
+--
+2.24.1
+