summaryrefslogtreecommitdiff
path: root/app-doc/doxygen/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-doc/doxygen/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch96
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch32
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch24
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch20
4 files changed, 172 insertions, 0 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch b/app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch
new file mode 100644
index 000000000000..24a3b64ad3e1
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch
@@ -0,0 +1,96 @@
+From 5fcb13572417a3b4a05217e9023c683864f35643 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Thu, 19 Nov 2015 12:00:54 +0100
+Subject: [PATCH] Support flex-2.6.0
+
+The version checks only considered YY_FLEX_SUBMINOR_VERSION and did not
+take YY_FLEX_MINOR_VERSION into account, which made them fail with
+flex-2.6.0.
+
+diff --git a/src/code.l b/src/code.l
+index 3323580..25719af 100644
+--- a/src/code.l
++++ b/src/code.l
+@@ -3700,7 +3700,7 @@ void codeFreeScanner()
+ extern "C" { // some bogus code to keep the compiler happy
+ void codeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
+ #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
+ #endif
+
+diff --git a/src/commentscan.l b/src/commentscan.l
+index cf892a0..2629857 100644
+--- a/src/commentscan.l
++++ b/src/commentscan.l
+@@ -1128,7 +1128,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
+ // but we need to know the position in the input buffer where this
+ // rule matched.
+ // for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
+-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
++#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
+ inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf);
+ #else
+ inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf);
+@@ -1190,7 +1190,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
+ g_memberGroupHeader.resize(0);
+ parseMore=TRUE;
+ needNewEntry = TRUE;
+-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
++#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
+ inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext);
+ #else
+ inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext);
+diff --git a/src/fortrancode.l b/src/fortrancode.l
+index fb91a83..352912b 100644
+--- a/src/fortrancode.l
++++ b/src/fortrancode.l
+@@ -1306,7 +1306,7 @@ void parseFortranCode(CodeOutputInterface &od,const char *className,const QCStri
+ extern "C" { // some bogus code to keep the compiler happy
+ void fortrancodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
+ #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
+ #else
+ extern "C" { // some bogus code to keep the compiler happy
+diff --git a/src/pycode.l b/src/pycode.l
+index 3c41a69..f58f7c1 100644
+--- a/src/pycode.l
++++ b/src/pycode.l
+@@ -1503,7 +1503,7 @@ void parsePythonCode(CodeOutputInterface &od,const char * /*className*/,
+ extern "C" { // some bogus code to keep the compiler happy
+ void pycodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
+ #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
+ #endif
+
+diff --git a/src/vhdlcode.l b/src/vhdlcode.l
+index 369ae48..6957048 100644
+--- a/src/vhdlcode.l
++++ b/src/vhdlcode.l
+@@ -1613,7 +1613,7 @@ void codeFreeVhdlScanner()
+ extern "C" { // some bogus code to keep the compiler happy
+ void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
+ #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
+ #endif
+
+diff --git a/src/xmlcode.l b/src/xmlcode.l
+index 15b5d7e..2bef4a0 100644
+--- a/src/xmlcode.l
++++ b/src/xmlcode.l
+@@ -407,7 +407,7 @@ void resetXmlCodeParserState()
+ extern "C" { // some bogus code to keep the compiler happy
+ void xmlcodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
+ #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
+ #endif
+
diff --git a/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch
new file mode 100644
index 000000000000..cdc630c4d42b
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.12-link_with_pthread.patch
@@ -0,0 +1,32 @@
+diff --git a/addon/doxysearch/CMakeLists.txt b/addon/doxysearch/CMakeLists.txt
+index 33e01c1..165fc3e 100644
+--- a/addon/doxysearch/CMakeLists.txt
++++ b/addon/doxysearch/CMakeLists.txt
+@@ -20,6 +20,7 @@ target_link_libraries(doxyindexer
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
+ qtools
++ pthread
+ )
+
+ add_executable(doxysearch.cgi
+@@ -29,6 +30,7 @@ target_link_libraries(doxysearch.cgi
+ ${XAPIAN_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
++ pthread
+ )
+
+ install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
+diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
+index bf2eda8..8eb2a1c 100644
+--- a/addon/doxywizard/CMakeLists.txt
++++ b/addon/doxywizard/CMakeLists.txt
+@@ -109,6 +109,7 @@ ${doxywizard_RESOURCES_RCC}
+ qt_use_modules(doxywizard Core Gui Widgets Xml)
+ target_link_libraries(doxywizard
+ ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY}
++pthread
+ )
+
+ install(TARGETS doxywizard DESTINATION bin)
diff --git a/app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch b/app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch
new file mode 100644
index 000000000000..8d72e8ff6e0d
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.13-NULL-dereference.patch
@@ -0,0 +1,24 @@
+From 0f02761a158a5e9ddbd5801682482af8986dbc35 Mon Sep 17 00:00:00 2001
+From: albert-github <albert.tests@gmail.com>
+Date: Wed, 4 Jan 2017 12:24:55 +0100
+Subject: [PATCH] Bug 776791 - [1.8.13 Regression] Segfault building the
+ breathe docs
+
+Protected against NULL pointer of variable al
+---
+ src/xmlgen.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/xmlgen.cpp b/src/xmlgen.cpp
+index fe95c7a..70e198a 100644
+--- a/src/xmlgen.cpp
++++ b/src/xmlgen.cpp
+@@ -620,7 +620,7 @@ static void generateXMLForMember(MemberDef *md,FTextStream &ti,FTextStream &t,De
+ if (md->isInline()) t << "yes"; else t << "no";
+ t << "\"";
+
+- if (al->refQualifier!=RefQualifierNone)
++ if (al!=0 && al->refQualifier!=RefQualifierNone)
+ {
+ t << " refqual=\"";
+ if (al->refQualifier==RefQualifierLValue) t << "lvalue"; else t << "rvalue";
diff --git a/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch b/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch
new file mode 100644
index 000000000000..cfa56174c5eb
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch
@@ -0,0 +1,20 @@
+removeEmptyLines() segfaults on empty string
+
+https://bugs.gentoo.org/show_bug.cgi?id=454348
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676423
+
+Patch written by Thibaut Paumard <paumard@users.sourceforge.net>
+--- a/src/htmlgen.cpp
++++ b/src/htmlgen.cpp
+@@ -1022,6 +1022,11 @@
+ static QCString removeEmptyLines(const QCString &s)
+ {
+ BufStr out(s.length()+1);
++ if (s.length()==0)
++ {
++ out.addChar('\0');
++ return out.data();
++ }
+ const char *p=s.data();
+ if (p)
+ {