summaryrefslogtreecommitdiff
path: root/app-doc/devmanual/devmanual-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /app-doc/devmanual/devmanual-9999.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'app-doc/devmanual/devmanual-9999.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index b71b47820054..8ad5f06a357e 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
@@ -10,7 +10,7 @@ HOMEPAGE="https://devmanual.gentoo.org/"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/devmanual.git"
else
SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
@@ -18,11 +18,16 @@ fi
LICENSE="CC-BY-SA-3.0"
SLOT="0"
-IUSE=""
+IUSE="+fallback"
-DEPEND="dev-libs/libxslt
+BDEPEND="dev-libs/libxslt
media-gfx/imagemagick[truetype,svg,png]"
+src_prepare() {
+ default
+ use fallback && eapply "${FILESDIR}"/${PN}-fallback.patch
+}
+
src_compile() {
# Imagemagick uses inkscape (if present) to delegate
# svg conversions.