summaryrefslogtreecommitdiff
path: root/app-doc/devmanual/devmanual-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /app-doc/devmanual/devmanual-9999.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'app-doc/devmanual/devmanual-9999.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild29
1 files changed, 10 insertions, 19 deletions
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 1957ff9c99ef..7bea70d1e20b 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -29,35 +29,26 @@ BDEPEND="dev-libs/libxml2
PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
src_compile() {
- emake build OFFLINE=$(usex offline 1 0)
- use offline || emake documents.js
+ emake OFFLINE=$(usex offline 1 0)
}
src_install() {
- # clean out XML/XSL before installing
- find . \( \
- -iname '*.xml' -o \
- -iname '*.dtd' -o \
- -iname '*.xsl' -o \
- -iname '*.svg' \) -delete || die
- rm -r bin xsl .git* LICENSE Makefile README.md || die
-
- local HTML_DOCS=( . )
- einstalldocs
+ emake OFFLINE=$(usex offline 1 0) \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
offline mode, point your browser to the following url:
file://${EPREFIX}/usr/share/doc/${PF}/html/index.html"
+ if ! has_version app-doc/eclass-manpages; then
+ DOC_CONTENTS+="\\n\\nThe offline version of the devmanual does not
+ include the documentation for the eclasses. If you need it,
+ then emerge app-doc/eclass-manpages."
+ fi
readme.gentoo_create_doc
}
pkg_postinst() {
readme.gentoo_print_elog
- if ! has_version app-doc/eclass-manpages; then
- elog "The offline version of the devmanual does not include the"
- elog "documentation for the eclasses. If you need it, then emerge"
- elog "the following package:"
- elog
- elog "app-doc/eclass-manpages"
- fi
}