summaryrefslogtreecommitdiff
path: root/app-doc/devmanual/devmanual-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-doc/devmanual/devmanual-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-doc/devmanual/devmanual-9999.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
new file mode 100644
index 000000000000..27453deb6185
--- /dev/null
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit git-2 readme.gentoo
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="https://devmanual.gentoo.org/"
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-libs/libxslt
+ media-gfx/imagemagick[truetype,svg,png]"
+
+DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ /usr/share/doc/devmanual/html/index.html"
+
+src_compile() {
+ # Imagemagick uses inkscape (if present) to delegate
+ # svg conversions.
+ # Inkscape uses g_get_user_config_dir () which in turn
+ # uses XDG_CONFIG_HOME to get the config directory for this
+ # user. See bug 463380
+ export XDG_CONFIG_HOME="${T}/inkscape_home"
+ emake
+}
+
+src_install() {
+ dohtml -r *
+ einfo "Creating symlink from ${PF} to ${PN} for preserving bookmarks"
+ dosym ${PF} /usr/share/doc/${PN}
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version app-portage/eclass-manpages; then
+ elog "The offline version of the devmanual does not include the"
+ elog "documentation for the eclasses. If you need it, then emerge"
+ elog "the following package:"
+ elog
+ elog "app-portage/eclass-manpages"
+ elog
+ fi
+}