summaryrefslogtreecommitdiff
path: root/app-doc/devmanual/devmanual-0_pre20210118.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /app-doc/devmanual/devmanual-0_pre20210118.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'app-doc/devmanual/devmanual-0_pre20210118.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-0_pre20210118.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-doc/devmanual/devmanual-0_pre20210118.ebuild b/app-doc/devmanual/devmanual-0_pre20210118.ebuild
new file mode 100644
index 000000000000..1170493b93eb
--- /dev/null
+++ b/app-doc/devmanual/devmanual-0_pre20210118.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7,8,9})
+
+inherit python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="https://devmanual.gentoo.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/devmanual.git"
+else
+ # "make dist" in devmanual repo
+ SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+ S="${WORKDIR}/${PN}"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE="+offline"
+
+BDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ gnome-base/librsvg
+ media-fonts/open-sans
+ ${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
+
+src_compile() {
+ emake OFFLINE=$(usex offline 1 0)
+}
+
+src_install() {
+ emake OFFLINE=$(usex offline 1 0) \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ file://${EPREFIX}/usr/share/doc/${PF}/html/index.html"
+ if ! has_version app-doc/eclass-manpages; then
+ DOC_CONTENTS+="\\n\\nThe offline version of the devmanual does not
+ include the documentation for the eclasses. If you need it,
+ then emerge app-doc/eclass-manpages."
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}